Bug 1400237 - Ganesha services are not stopped when pacemaker quorum is lost
Summary: Ganesha services are not stopped when pacemaker quorum is lost
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: common-ha
Version: mainline
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kaleb KEITHLEY
QA Contact:
URL:
Whiteboard:
Depends On: 1399757
Blocks: 1400572 1400573
TreeView+ depends on / blocked
 
Reported: 2016-11-30 17:40 UTC by Kaleb KEITHLEY
Modified: 2017-03-06 17:37 UTC (History)
11 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1399757
: 1400572 (view as bug list)
Environment:
Last Closed: 2017-01-24 11:42:24 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2016-11-30 18:19:08 UTC
REVIEW: http://review.gluster.org/15981 (common-ha: IPaddr RA is not stopped when pacemaker quorum is list) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 2 Worker Ant 2016-11-30 18:25:42 UTC
REVIEW: http://review.gluster.org/15981 (common-ha: IPaddr RA is not stopped when pacemaker quorum is list) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 3 Worker Ant 2016-12-01 15:07:58 UTC
COMMIT: http://review.gluster.org/15981 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit bdcc3ac42b6247329578c984403bac1cf8a2c02e
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Wed Nov 30 13:00:16 2016 -0500

    common-ha: IPaddr RA is not stopped when pacemaker quorum is list
    
    Ken Gaillot writes:
    The other is pacemaker's no-quorum-policy cluster property. The
    default (which has not changed) is "stop" (stop all resources).
    Other values are "ignore" (act as if quorum was not lost),
    "freeze" (continue running existing resources but don't recover
    resources from unseen nodes) or "suicide" (shut down).
    
    But on my four node cluster
    % pcs property show no-quorum-policy
    Cluster Properties:
    %
    
    i.e. shows nothing.
    
    But:
    % pcs property list --all
    Cluster Properties:
    ...
     no-quorum-policy: stop
    ...
    %
    
    Seems to think it knows about it.
    
    and then
    % pcs property set no-quorum-policy=stop
    % pcs property show no-quorum-policy
    Cluster Properties:
     no-quorum-policy: stop
    %
    
    Which looks rather inconsistent. So we will try explicitly
    setting it to "stop" when there are three or more nodes.
    
    Change-Id: I47fc7ee84fcd6ad52ccb776913511978a8d517b4
    BUG: 1400237
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/15981
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: soumya k <skoduri@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 4 Kaleb KEITHLEY 2017-01-24 11:42:24 UTC
not relevant to master/main branch as of 3.10. Fix is on the release-3.9 branch

Comment 5 Shyamsundar 2017-03-06 17:37:56 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.