Bug 1400573 - Ganesha services are not stopped when pacemaker quorum is lost
Summary: Ganesha services are not stopped when pacemaker quorum is lost
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: common-ha
Version: 3.8
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1399757 1400237 1400572
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-01 14:08 UTC by Kaleb KEITHLEY
Modified: 2016-12-21 23:21 UTC (History)
11 users (show)

Fixed In Version: glusterfs-3.8.7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1400572
Environment:
Last Closed: 2016-12-14 07:13:24 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2016-12-01 15:28:55 UTC
REVIEW: http://review.gluster.org/15997 (common-ha: IPaddr RA is not stopped when pacemaker quorum is lost) posted (#2) for review on release-3.8 by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 2 Worker Ant 2016-12-02 09:54:06 UTC
COMMIT: http://review.gluster.org/15997 committed in release-3.8 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 377c3a00e2137c98fa4ffe52460dc17c8f2f8606
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Thu Dec 1 09:40:33 2016 -0500

    common-ha: IPaddr RA is not stopped when pacemaker quorum is lost
    
    Ken Gaillot writes:
    The other is pacemaker's no-quorum-policy cluster property. The
    default (which has not changed) is "stop" (stop all resources).
    Other values are "ignore" (act as if quorum was not lost),
    "freeze" (continue running existing resources but don't recover
    resources from unseen nodes) or "suicide" (shut down).
    
    But on my four node cluster
    % pcs property show no-quorum-policy
    Cluster Properties:
    %
    
    i.e. shows nothing.
    
    But:
    % pcs property list --all
    Cluster Properties:
    ...
    no-quorum-policy: stop
    ...
    %
    
    Seems to think it knows about it.
    
    and then
    % pcs property set no-quorum-policy=stop
    % pcs property show no-quorum-policy
    Cluster Properties:
     no-quorum-policy: stop
    %
    
    Which looks rather inconsistent. So we will try explicitly
    setting it to "stop" when there are three or more nodes.
    
    master bug 1400237
    master patch http://review.gluster.org/#/c/15981/
    release-3.9 bug 1400527
    release-3.9 patch http://review.gluster.org/15996
    
    Change-Id: I47fc7ee84fcd6ad52ccb776913511978a8d517b4
    BUG: 1400573
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/15997
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>

Comment 3 Niels de Vos 2016-12-14 07:13:24 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.7, please open a new bug report.

glusterfs-3.8.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/packaging/2016-December/000226.html
[2] https://www.gluster.org/pipermail/gluster-users/

Comment 4 Worker Ant 2016-12-21 23:21:28 UTC
REVIEW: http://review.gluster.org/16247 (common-ha: IPaddr RA is not stopped when pacemaker quorum is lost) posted (#1) for review on release-3.8-fb by Kevin Vigor (kvigor@fb.com)


Note You need to log in before you can comment on or make changes to this bug.