Bug 1400693 - Latest libnl3 does not provide libnl-3.so.200(libnl_3)(64bit), only libnl-3.so.200()(64bit)
Summary: Latest libnl3 does not provide libnl-3.so.200(libnl_3)(64bit), only libnl-3.s...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: ocserv
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nikos Mavrogiannopoulos
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1400744 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-01 21:08 UTC by David Schlenk
Modified: 2016-12-13 08:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-08 08:52:20 UTC


Attachments (Terms of Use)

Description David Schlenk 2016-12-01 21:08:04 UTC
Description of problem:
0.11.6-1 of ocserv has the following dependencies related to libnl3:
$ yum deplist ocserv | grep libnl
  dependency: libnl-3.so.200()(64bit)
   provider: libnl3.x86_64 3.2.21-10.el7
  dependency: libnl-3.so.200(libnl_3)(64bit)
  dependency: libnl-route-3.so.200()(64bit)
   provider: libnl3.x86_64 3.2.21-10.el7
  dependency: libnl-route-3.so.200(libnl_3)(64bit)

The latest libnl3 package no longer provides libnl-3.so.200()(64bit):
$ rpm -qi --provides libnl3
Name        : libnl3
Version     : 3.2.21
Release     : 10.el7
Architecture: x86_64
Install Date: Tue 19 Jul 2016 07:54:31 PM UTC
Group       : Development/Libraries
Size        : 596320
License     : LGPLv2
Signature   : RSA/SHA256, Wed 25 Nov 2015 03:00:46 PM UTC, Key ID 24c6a8a7f4a80eb5
Source RPM  : libnl3-3.2.21-10.el7.src.rpm
Build Date  : Fri 20 Nov 2015 06:55:31 AM UTC
Build Host  : worker1.bsys.centos.org
Relocations : (not relocatable)
Packager    : CentOS BuildSystem <http://bugs.centos.org>
Vendor      : CentOS
URL         : http://www.infradead.org/~tgr/libnl/
Summary     : Convenience library for kernel netlink sockets
Description :
This package contains a convenience library to simplify
using the Linux kernel's netlink sockets interface for
network manipulation
config(libnl3) = 3.2.21-10.el7
libnl-3.so.200()(64bit)
libnl-genl-3.so.200()(64bit)
libnl-nf-3.so.200()(64bit)
libnl-route-3.so.200()(64bit)
libnl3 = 3.2.21-10.el7
libnl3(x86-64) = 3.2.21-10.el7

Version-Release number of selected component (if applicable):
0.11.6-1.el7

How reproducible:
Always


Steps to Reproduce:
1. Fresh CentOS 7.2 install
2. Install epel 7
3. yum install ocserv

Actual results:
$ sudo yum install ocserv
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: repo1.dal.innoscale.net
 * epel: mirror.steadfast.net
 * extras: centos.mirror.constant.com
 * updates: mirror.team-cymru.org
Resolving Dependencies
--> Running transaction check
---> Package ocserv.x86_64 0:0.11.6-1.el7 will be installed
--> Processing Dependency: libradcli.so.4(RADCLI_4)(64bit) for package: ocserv-0.11.6-1.el7.x86_64
--> Processing Dependency: libprotobuf-c.so.1(LIBPROTOBUF_C_1.0.0)(64bit) for package: ocserv-0.11.6-1.el7.x86_64
--> Processing Dependency: libnl-route-3.so.200(libnl_3)(64bit) for package: ocserv-0.11.6-1.el7.x86_64
--> Processing Dependency: libnl-3.so.200(libnl_3)(64bit) for package: ocserv-0.11.6-1.el7.x86_64
--> Processing Dependency: gnutls-utils for package: ocserv-0.11.6-1.el7.x86_64
--> Processing Dependency: libseccomp.so.2()(64bit) for package: ocserv-0.11.6-1.el7.x86_64
--> Processing Dependency: libradcli.so.4()(64bit) for package: ocserv-0.11.6-1.el7.x86_64
--> Processing Dependency: libprotobuf-c.so.1()(64bit) for package: ocserv-0.11.6-1.el7.x86_64
--> Processing Dependency: libpcl.so.1()(64bit) for package: ocserv-0.11.6-1.el7.x86_64
--> Processing Dependency: libopts.so.25()(64bit) for package: ocserv-0.11.6-1.el7.x86_64
--> Processing Dependency: liblz4.so.1()(64bit) for package: ocserv-0.11.6-1.el7.x86_64
--> Processing Dependency: libhttp_parser.so.2()(64bit) for package: ocserv-0.11.6-1.el7.x86_64
--> Processing Dependency: libev.so.4()(64bit) for package: ocserv-0.11.6-1.el7.x86_64
--> Running transaction check
---> Package autogen-libopts.x86_64 0:5.18-5.el7 will be installed
---> Package gnutls-utils.x86_64 0:3.3.8-14.el7_2 will be installed
--> Processing Dependency: gnutls-dane(x86-64) = 3.3.8-14.el7_2 for package: gnutls-utils-3.3.8-14.el7_2.x86_64
--> Processing Dependency: gnutls(x86-64) = 3.3.8-14.el7_2 for package: gnutls-utils-3.3.8-14.el7_2.x86_64
--> Processing Dependency: libgnutls-dane.so.0(DANE_0_0)(64bit) for package: gnutls-utils-3.3.8-14.el7_2.x86_64
--> Processing Dependency: libunbound.so.2()(64bit) for package: gnutls-utils-3.3.8-14.el7_2.x86_64
--> Processing Dependency: libgnutls-dane.so.0()(64bit) for package: gnutls-utils-3.3.8-14.el7_2.x86_64
---> Package http-parser.x86_64 0:2.0-5.20121128gitcd01361.el7 will be installed
---> Package libev.x86_64 0:4.15-6.el7 will be installed
---> Package libseccomp.x86_64 0:2.2.1-1.el7 will be installed
---> Package lz4.x86_64 0:r131-1.el7 will be installed
---> Package ocserv.x86_64 0:0.11.6-1.el7 will be installed
--> Processing Dependency: libnl-route-3.so.200(libnl_3)(64bit) for package: ocserv-0.11.6-1.el7.x86_64
--> Processing Dependency: libnl-3.so.200(libnl_3)(64bit) for package: ocserv-0.11.6-1.el7.x86_64
---> Package pcllib.x86_64 0:1.12-1.el7 will be installed
---> Package protobuf-c.x86_64 0:1.0.2-2.el7 will be installed
---> Package radcli.x86_64 0:1.2.5-1.el7 will be installed
--> Running transaction check
---> Package gnutls.x86_64 0:3.3.8-12.el7_1.1 will be updated
---> Package gnutls.x86_64 0:3.3.8-14.el7_2 will be an update
---> Package gnutls-dane.x86_64 0:3.3.8-14.el7_2 will be installed
---> Package ocserv.x86_64 0:0.11.6-1.el7 will be installed
--> Processing Dependency: libnl-route-3.so.200(libnl_3)(64bit) for package: ocserv-0.11.6-1.el7.x86_64
--> Processing Dependency: libnl-3.so.200(libnl_3)(64bit) for package: ocserv-0.11.6-1.el7.x86_64
---> Package unbound-libs.x86_64 0:1.4.20-26.el7 will be installed
--> Processing Dependency: libldns.so.1()(64bit) for package: unbound-libs-1.4.20-26.el7.x86_64
--> Running transaction check
---> Package ldns.x86_64 0:1.6.16-7.el7 will be installed
---> Package ocserv.x86_64 0:0.11.6-1.el7 will be installed
--> Processing Dependency: libnl-route-3.so.200(libnl_3)(64bit) for package: ocserv-0.11.6-1.el7.x86_64
--> Processing Dependency: libnl-3.so.200(libnl_3)(64bit) for package: ocserv-0.11.6-1.el7.x86_64
--> Finished Dependency Resolution
Error: Package: ocserv-0.11.6-1.el7.x86_64 (epel)
           Requires: libnl-route-3.so.200(libnl_3)(64bit)
Error: Package: ocserv-0.11.6-1.el7.x86_64 (epel)
           Requires: libnl-3.so.200(libnl_3)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results:
successful installation

Additional info:

Comment 1 Tuomo Soini 2016-12-01 21:27:59 UTC
That is a problem with you running too old centos version.

Comment 2 David Schlenk 2016-12-01 21:47:42 UTC
(In reply to Tuomo Soini from comment #1)
> That is a problem with you running too old centos version.

Indeed, I had not run a full yum update on this system. However, that doesn't change the fact that libnl3 no longer provides 'libnl-3.so.200(libnl_3)(64bit)' which ocserv-0.11.6-1.el7.x86_64 requires. 

I just now tried:
yum update
(new kernel, reboot)
yum clean all
yum install ocserv

with basically the same dependency failure. Just more concise:

$ sudo reboot
PolicyKit daemon disconnected from the bus.
We are no longer a registered authentication agent.
Connection to 127.0.0.1 closed by remote host.
Connection to 127.0.0.1 closed.
shorter:ocserv-cookbook schlazor$ kitchen login default-service-centos-72
Last login: Thu Dec  1 21:38:13 2016 from 10.0.2.2
[vagrant@default-service-centos-72 ~]$ sudo yum install ocserv
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: repo1.dal.innoscale.net
 * epel: mirror.cogentco.com
 * extras: mirror.tzulo.com
 * updates: mirror.cisp.com
Resolving Dependencies
--> Running transaction check
---> Package ocserv.x86_64 0:0.11.6-1.el7 will be installed
--> Processing Dependency: libnl-route-3.so.200(libnl_3)(64bit) for package: ocserv-0.11.6-1.el7.x86_64
--> Processing Dependency: libnl-3.so.200(libnl_3)(64bit) for package: ocserv-0.11.6-1.el7.x86_64
--> Finished Dependency Resolution
Error: Package: ocserv-0.11.6-1.el7.x86_64 (epel)
           Requires: libnl-route-3.so.200(libnl_3)(64bit)
Error: Package: ocserv-0.11.6-1.el7.x86_64 (epel)
           Requires: libnl-3.so.200(libnl_3)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[vagrant@default-service-centos-72 ~]$ sudo yum clean all
Loaded plugins: fastestmirror
Cleaning repos: base epel extras updates
Cleaning up everything
Cleaning up list of fastest mirrors
[vagrant@default-service-centos-72 ~]$ sudo yum install ocserv
Loaded plugins: fastestmirror
base                                                                                                                                     | 3.6 kB  00:00:00     
epel/x86_64/metalink                                                                                                                     |  12 kB  00:00:00     
epel                                                                                                                                     | 4.3 kB  00:00:00     
extras                                                                                                                                   | 3.4 kB  00:00:00     
updates                                                                                                                                  | 3.4 kB  00:00:00     
(1/7): base/7/x86_64/group_gz                                                                                                            | 155 kB  00:00:00     
(2/7): epel/x86_64/group_gz                                                                                                              | 170 kB  00:00:00     
(3/7): epel/x86_64/updateinfo                                                                                                            | 681 kB  00:00:00     
(4/7): extras/7/x86_64/primary_db                                                                                                        | 166 kB  00:00:00     
(5/7): updates/7/x86_64/primary_db                                                                                                       | 9.1 MB  00:00:02     
(6/7): epel/x86_64/primary_db                                                                                                            | 4.4 MB  00:00:03     
(7/7): base/7/x86_64/primary_db                                                                                                          | 5.3 MB  00:00:08     
Determining fastest mirrors
 * base: repo1.dal.innoscale.net
 * epel: mirror.cogentco.com
 * extras: mirrors.tummy.com
 * updates: centos.mirrors.tds.net
Resolving Dependencies
--> Running transaction check
---> Package ocserv.x86_64 0:0.11.6-1.el7 will be installed
--> Processing Dependency: libnl-route-3.so.200(libnl_3)(64bit) for package: ocserv-0.11.6-1.el7.x86_64
--> Processing Dependency: libnl-3.so.200(libnl_3)(64bit) for package: ocserv-0.11.6-1.el7.x86_64
--> Finished Dependency Resolution
Error: Package: ocserv-0.11.6-1.el7.x86_64 (epel)
           Requires: libnl-route-3.so.200(libnl_3)(64bit)
Error: Package: ocserv-0.11.6-1.el7.x86_64 (epel)
           Requires: libnl-3.so.200(libnl_3)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 3 Nikos Mavrogiannopoulos 2016-12-02 13:00:32 UTC
*** Bug 1400744 has been marked as a duplicate of this bug. ***

Comment 4 Tuomo Soini 2016-12-02 13:05:32 UTC
Using centos CR repo to update system should help. This is change from rhel-7.3 so centos-7.3 is needed for this package.

Comment 5 Fedora Update System 2016-12-02 13:10:33 UTC
ocserv-0.11.6-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-c819074d1e

Comment 6 Fedora Update System 2016-12-02 13:37:13 UTC
ocserv-0.11.6-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-8e42046775

Comment 7 Nikos Mavrogiannopoulos 2016-12-02 13:37:58 UTC
I've submitted an update which compiles without libnl3 for the interim.

Comment 8 Nikos Mavrogiannopoulos 2016-12-02 14:36:34 UTC
(In reply to Fedora Update System from comment #6)
> ocserv-0.11.6-3.el7 has been submitted as an update to Fedora EPEL 7.
> https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-8e42046775

If that works for you please login and add karma to the URL above.

Comment 9 Nikos Mavrogiannopoulos 2016-12-02 14:38:01 UTC
You can try using the builds in koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=822092

Comment 10 hlx98007 2016-12-02 14:44:35 UTC
0.11.6-3 installs well.

Comment 11 Fedora Update System 2016-12-03 11:19:21 UTC
ocserv-0.11.6-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2016-8e42046775

Comment 12 Nikos Mavrogiannopoulos 2016-12-05 08:02:35 UTC
I'm withdrawing the fix then. As it is now, I think the only reasonable solution is to wait for centos7.3.

Comment 13 Nikos Mavrogiannopoulos 2016-12-13 08:09:39 UTC
This issue should be addressed with Centos 7.3.


Note You need to log in before you can comment on or make changes to this bug.