This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 140159 - up2date4-3.53-1 remove the /etc/sysconfig/rhn/sources file during the own update
up2date4-3.53-1 remove the /etc/sysconfig/rhn/sources file during the own update
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-20 08:05 EST by Uwe Beck
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-22 12:49:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
messages during up2date on console (3.89 KB, text/plain)
2004-11-20 08:09 EST, Uwe Beck
no flags Details

  None (edit)
Description Uwe Beck 2004-11-20 08:05:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20041020

Description of problem:
up2date-4.3.53-1 comes as a fix for bug #138754. Befor I start up2date
the redhat-release-3.95ES-3 rpm was not installed on the system. That
this rpm can not install was the problem in #138754.

Update up2date self is the first step in this update process. Then
up2date ask for restart. I do this.

New Up2date available
New Up2date available
Restarting up2date
Restarting up2date

But then the up2date can not do the rest of updates. Only a kill -9 helps.

Start new up2date:
# up2date&
warning: can't access /etc/sysconfig/rhn/sources

--> unable to use the RHN

To fix this problem I have install redhat-release-3.95ES-3 by hand.


Version-Release number of selected component (if applicable):
up2date-4.3.53-1

How reproducible:
Always

Steps to Reproduce:
1. use up2date to update RHEL4_BETA2
2.
3.
    

Actual Results:  /etc/sysconfig/rhn/sources removed during up2date update

Expected Results:  should work correct

Additional info:
Comment 1 Uwe Beck 2004-11-20 08:09:27 EST
Created attachment 107114 [details]
messages during up2date on console
Comment 2 Uwe Beck 2004-11-21 18:19:40 EST
Does RHEL4 up2date use a new philosophy?

# rpm -qf /etc/sysconfig/rhn/sources
redhat-release-3.95ES-3

But before up2date-4.3.53-1
# rpm -qf /etc/sysconfig/rhn/sources
up2date-4.2.38-1

I think up2date should contain /etc/sysconfig/rhn/sources. So it is
logic for me.
Comment 3 Adrian Likins 2004-11-22 12:49:16 EST
redhat-release contains 
/etc/sysconfig/rhn/sources now (since it
changes between RHEL/Fedora/etc). 

up2date pretty much requires some variant
of *-release to be installed (it would
explicitly Require it, but the package name
changes on different releases, and *-release
is a Base package). 

Aside from #138754, this should be fine for
final release. 
Comment 4 Uwe Beck 2004-11-23 04:19:22 EST
Thank you for this information. This is o.k..

Note You need to log in before you can comment on or make changes to this bug.