This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 140166 - Latest kernel dumps upon sync of Palm device
Latest kernel dumps upon sync of Palm device
Status: CLOSED DUPLICATE of bug 140005
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-20 09:36 EST by Mike Burger
Modified: 2015-01-04 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-20 10:51:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike Burger 2004-11-20 09:36:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040808 Firefox/0.9.3

Description of problem:
This does not happen with kernel 2.6.8-1.521.

Upon selecting to synchronize my palm unit, no synchronization occurs,
and a dump/trace appears in the messages log:

Version-Release number of selected component (if applicable):
2.6.9-1.3_FC2

How reproducible:
Always

Steps to Reproduce:
1. Boot up system using 2.6.9-1.3_FC2 kernel
2. Start up pilot sync tool (I'm using jpilot-sync
3. press synchronize button on Palm device
    

Actual Results:  The palm did not synchronize, and the above-noted
output appeared

Expected Results:  The palm should have synchronized

Additional info:
Comment 1 Mike Burger 2004-11-20 09:37:05 EST
/var/log/messages dump info:

Nov 20 09:31:03 winblows kernel: usb 2-2: Handspring Visor / Palm OS
converter n
ow attached to ttyUSB0
Nov 20 09:31:03 winblows kernel: usb 2-2: Handspring Visor / Palm OS
converter n
ow attached to ttyUSB1
Nov 20 09:31:03 winblows kernel: usbcore: registered new driver visor
Nov 20 09:31:03 winblows kernel: drivers/usb/serial/visor.c: USB
HandSpring Viso
r / Palm OS driver v2.1
Nov 20 09:31:03 winblows kernel: Debug: sleeping function called from
invalid co
ntext at include/linux/rwsem.h:43
Nov 20 09:31:03 winblows kernel: in_atomic():0[expected: 0],
irqs_disabled():1
Nov 20 09:31:03 winblows kernel:  [<0211c967>] __might_sleep+0x82/0x8c
Nov 20 09:31:03 winblows kernel:  [<0215ebdd>] rw_vm+0x20d/0x467
Nov 20 09:31:03 winblows kernel:  [<22b3706c>] visor_open+0x6c/0x24c
[visor]
Nov 20 09:31:03 winblows kernel:  [<22b3706c>] visor_open+0x6c/0x24c
[visor]
Nov 20 09:31:03 winblows kernel:  [<0215f326>] get_user_size+0x2e/0x55
Nov 20 09:31:03 winblows kernel:  [<22b3706c>] visor_open+0x6c/0x24c
[visor]
Nov 20 09:31:03 winblows kernel:  [<021192e5>] __is_prefetch+0x1a2/0x290
Nov 20 09:31:03 winblows kernel:  [<22b3706c>] visor_open+0x6c/0x24c
[visor]
Nov 20 09:31:03 winblows kernel:  [<021196f3>] do_page_fault+0x320/0x4ff
Nov 20 09:31:03 winblows kernel:  [<021c6244>] inode_has_perm+0x57/0x5f
Nov 20 09:31:03 winblows kernel:  [<021c4bfe>] avc_has_perm+0x3f/0x49
Nov 20 09:31:03 winblows kernel:  [<02147328>]
buffered_rmqueue+0x1e9/0x20c
Nov 20 09:31:03 winblows kernel:  [<021193d3>] do_page_fault+0x0/0x4ff
Nov 20 09:31:03 winblows kernel:  [<22b3706c>] visor_open+0x6c/0x24c
[visor]
Nov 20 09:31:03 winblows kernel:  [<22b2f2e4>] serial_open+0x95/0xd9
[usbserial]
Nov 20 09:31:03 winblows kernel:  [<0221def0>] tty_open+0x139/0x36c
Nov 20 09:31:03 winblows kernel:  [<02170be8>] chrdev_open+0x3bd/0x458
Nov 20 09:31:04 winblows kernel:  [<021650d9>] dentry_open+0xbd/0x180
Nov 20 09:31:04 winblows kernel:  [<02165016>] filp_open+0x36/0x3c
Nov 20 09:31:04 winblows kernel:  [<0216552c>] sys_open+0x31/0x7d
Nov 20 09:31:04 winblows kernel: Unable to handle kernel NULL pointer
dereferenc
e at virtual address 00000000
Nov 20 09:31:04 winblows kernel:  printing eip:
Nov 20 09:31:04 winblows kernel: 22b3706c
Nov 20 09:31:04 winblows kernel: *pde = 00000000
Nov 20 09:31:04 winblows kernel: Oops: 0000 [#1]
Nov 20 09:31:04 winblows kernel: Modules linked in: visor usbserial
snd soundcor
e ipt_state ip_conntrack parport_pc lp parport osslinux(U) nfsd
exportfs md5 ipv
6 nfs lockd sunrpc via_rhine mii ipt_REJECT iptable_filter ip_tables
floppy sg d
m_mod uhci_hcd button battery ac ext3 jbd usb_storage ide_scsi aic7xxx
sd_mod sc
si_mod
Nov 20 09:31:04 winblows kernel: CPU:    0
Nov 20 09:31:04 winblows kernel: EIP:    0060:[<22b3706c>]    Tainted:
P   VLI
Nov 20 09:31:04 winblows kernel: EFLAGS: 00010006   (2.6.9-1.3_FC2)
Nov 20 09:31:04 winblows kernel: EIP is at visor_open+0x6c/0x24c [visor]
Nov 20 09:31:04 winblows kernel: eax: 21cb8600   ebx: 00000206   ecx:
22b3afa0
 edx: 10cd5720
Nov 20 09:31:04 winblows kernel: esi: 00000000   edi: 21cb8600   ebp:
150c0f60
 esp: 1899aed0
Nov 20 09:31:04 winblows kernel: ds: 007b   es: 007b   ss: 0068
Nov 20 09:31:04 winblows kernel: Process jpilot-sync (pid: 3879,
threadinfo=1899
a000 task=18b26650)
Nov 20 09:31:04 winblows kernel: Stack: 21cb8600 150c0f60 10c8b000
00000000 22b2
f2e4 10cd5720 ffffffed 10cd5720
Nov 20 09:31:04 winblows kernel:        10c8b000 00000000 0221def0
00000802 0bc0
0000 10c8b000 00000000 1899a000
Nov 20 09:31:04 winblows kernel:        1af25c04 2186fb00 00000000
02170be8 0000
0000 10cd5720 00000000 10cd5720
Nov 20 09:31:04 winblows kernel: Call Trace:
Nov 20 09:31:04 winblows kernel:  [<22b2f2e4>] serial_open+0x95/0xd9
[usbserial]
Nov 20 09:31:04 winblows kernel:  [<0221def0>] tty_open+0x139/0x36c
Nov 20 09:31:04 winblows kernel:  [<02170be8>] chrdev_open+0x3bd/0x458
Nov 20 09:31:04 winblows kernel:  [<021650d9>] dentry_open+0xbd/0x180
Nov 20 09:31:04 winblows kernel:  [<02165016>] filp_open+0x36/0x3c
Nov 20 09:31:04 winblows kernel:  [<0216552c>] sys_open+0x31/0x7d
Nov 20 09:31:04 winblows kernel: Code:  Bad EIP value.
Comment 2 Dave Jones 2004-11-20 10:51:40 EST

*** This bug has been marked as a duplicate of 140005 ***

Note You need to log in before you can comment on or make changes to this bug.