Bug 140005 - (visor_oops) Bad EIP value when connecting visor device
Bad EIP value when connecting visor device
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
: 139823 140166 140193 140269 140303 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-19 04:03 EST by Hugo Vandeputte
Modified: 2015-01-04 17:12 EST (History)
16 users (show)

See Also:
Fixed In Version: kernel-smp-2.6.9-1.698_FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-17 09:06:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
syslog extract (4.95 KB, text/plain)
2004-11-19 04:07 EST, Hugo Vandeputte
no flags Details
log messages from failed hotsync attempt (1.30 KB, text/plain)
2004-11-22 17:45 EST, James Ralston
no flags Details

  None (edit)
Description Hugo Vandeputte 2004-11-19 04:03:07 EST
Description of problem:
Error when connecting a visor device:
 Bad EIP value.
The /dev/ttyUSB? stay after deconnecting the device.

Version-Release number of selected component (if applicable):
kernel 2.6.9-1.678_FC3
All ok with 2.6.9-1.667

How reproducible:
every time.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Hugo Vandeputte 2004-11-19 04:07:30 EST
Created attachment 107041 [details]
syslog extract
Comment 2 Dave Jones 2004-11-20 10:51:52 EST
*** Bug 140166 has been marked as a duplicate of this bug. ***
Comment 3 Mike Burger 2004-11-21 18:57:25 EST
The only issue I have with marking the other as a duplicate is that
this bug, 140005, is specifically noted to be FC3, while 140166 was
marked for FC2.

I just want to make sure that it'll be looked at for both releases.

Thanks.
Comment 4 Dave Jones 2004-11-21 23:34:26 EST
the two trees are in sync with each other (and are 99.9% the same tree), so if
its fixed in one, the other will be fixed at the same time. 
Comment 5 Dave Jones 2004-11-21 23:35:00 EST
*** Bug 139823 has been marked as a duplicate of this bug. ***
Comment 6 Dave Jones 2004-11-21 23:35:12 EST
*** Bug 140193 has been marked as a duplicate of this bug. ***
Comment 7 Dave Jones 2004-11-21 23:35:25 EST
*** Bug 140269 has been marked as a duplicate of this bug. ***
Comment 8 Warren Togami 2004-11-22 05:36:47 EST
*** Bug 140303 has been marked as a duplicate of this bug. ***
Comment 9 James Ralston 2004-11-22 17:45:13 EST
Created attachment 107253 [details]
log messages from failed hotsync attempt

Okay, with kernel-2.6.9-1.6_FC2 I no longer get the "Unable to handle kernel
NULL pointer dereference at virtual address 00000000" error that I was getting
with kernel-2.6.9-1.3_FC2.

But I still can't successfully sync my Palm m505.  The sync starts, but
disconnects after a few seconds.  (See the log messages.)

There's nothing in 2.6.9 that I particularly need, so I'm dropping back to
kernel-2.6.8-1.521 for now.
Comment 10 Florin Andrei 2004-11-22 23:29:23 EST
Marginal improvement on FC3 with the 2.6.9-1.681_FC3 kernel. The sync
appears to start fine, but JPilot hangs at "Syncing AddressDB" while
the PDA tries to go further to saving the ToDo.
At least now the kernel does not oops, but the sync fails nevertheless.
Comment 11 Hugo Vandeputte 2004-11-23 06:57:27 EST
Oddly 2.6.9-1.681_FC3 seems to remove other kernels...
After 2.6.9-1.681_FC3 installation same behaviour as in comments #9 and
#10.
Back to 667:  rpm -ivh --force kernel-2.6.9-1.667.i686.rpm
reboot

Sync hangs and a new message appears:
 kernel: usb 4-2: control timeout on ep0in
Oops: 
 rpm -ivh --force kernel-utils-2.4-13.1.39.i386.rpm

All working fine.
Watching for some difference between kernel configs...,
but no results at the moment...

Comment 12 Peter Hunter 2004-11-23 08:46:59 EST
I see exactly the same as Florin Andrei above using 2.6.9-1.861_FC3
but using kpilot, not jpilot, suggesting a kernel bug rather than a
bug in either program. The Oops I was seeing has gone away, but I
still can't sync.
Comment 13 Nigel Metheringham 2004-11-23 08:57:38 EST
Confirm 2.6.9-1.681_FC3 removes Oops.

Something seems to have changed in that the permissions on the ttyUSB*
devices are such that they are no longer accessible to me - I see a
udev update in the right sort of timescale to affect this.

Trying a 
  pilot-xfer -L
as root gets the first part of the installed databases list, but
hangs part way through.  No error message regarding this is seen
in the kernel log or elsewhere except the palm device timing out
after a minute.  Not seeing USB timeout messages.
Comment 14 Paul W. Frields 2004-11-24 10:24:44 EST
Confirmed that I am seeing this problem as well, FC3, kernel 2.6.9-1.681_FC3,
USB connected Visor. Hardware is detected via USB, visor module loads,
/dev/ttyUSB* and /dev/pilot are created correctly (and owned corrrectly), the
gpilot-applet executes, but the Visor never leaves the "Identifying user" stage.
The gpilot-applet never reaches the stage where it exchanges data visibly,
although the progress indicator does continue to run, even after the Visor has
issued its own error and a USB disconnect happens.
Comment 15 Christopher A. Williams 2004-11-28 09:29:18 EST
This bug and my bug (140125) seem to be duplicates as well. They were
both opened within hours of each other and both are assigned to Dave
Jones. Should we close on of them as a dup?
Comment 16 Gideon N. Guillen 2004-11-28 12:34:42 EST
This bug is also reproducible on FC2 using the kernel 2.6.9-6 (FC2).
I'm using a Zire 31 and I am syncing it with MultiSync. Bug is also
reproducible in pilot-link command line tools. Trying 'dlpsh' and
doing an 'ls' command, the listing of palm dbs would halt after
listing a few of them.
Comment 17 Bob Arendt 2004-12-04 13:50:53 EST
This bug is fixed with latest kernel in updates-testing for me,
using a palm M125, modules visor + usbserial.  Working kernel:
kernel-smp-2.6.9-1.698_FC3.i686.rpm

Thanks!
Comment 18 Andrew Gilmore 2004-12-06 12:40:00 EST
Confirmed also working for me with that kernel (698), see comment in
chrisw's bug #140125
Comment 19 Paul W. Frields 2004-12-06 12:53:23 EST
Confirmed also working for me with kernel 2.6.9-1.698_FC3.
Comment 20 Mike Burger 2004-12-06 13:42:38 EST
Would someone please make a testing kernel available in the
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/2/i386/
directory, so those of us still at FC2 can test, as well?
Comment 21 Joe Acosta 2004-12-09 00:26:04 EST
I'm adding my 2 cents to this.  I'm experienceing the same problem as
you all.  I started having problems with my windows computer at work
(win 2k) and then tried to sync at home on my Linux pc and it failed
to sync in both places.  I thought it was a clie problem, so I've just
went through sony support, and was ready to return the device, when
after lots of googling I came across this bug. :-O I guess between my
last sync on my linux box I had upgraded to 2.6.9 from 2.6.8, and did
not test the pda, but tested the pwc phillips driver ;-).  

I just downgraded to 2.6.8 tonight after reading this ( actually I
have both kernels custom built on the box ) and 2.6.8 works awesome,
but 2.6.9-1.6_FC2custom does not work at all.  It does exactly the
same behavior, dlpsh ls fails to list the files, pilot-xfer exhibits
the same behavior.  

I just found the link to the updates, so I'll download that and test
it out too, because I want to use 2.6.9 with the pwc driver and the
visor driver fixes ( not tonight though).  

When will this new kernel be in the main FC 2 tree also?

Thanks lots!
Joe
Comment 22 Joe Acosta 2004-12-16 23:37:00 EST
I just installed and compiled kernel-sourcecode-2.6.9-1.9_FC2 from the
testing ftp link above.

The pilot-link ( sony clie ) ( and pwc driver ) work great!

Just synced up the pda.  Thanks!  
Comment 23 Nader Khalid Alzain 2004-12-17 08:55:13 EST
Palm Pilot m500 now works perfectly. Tested with kernel-2.6.9-
1.698_FC3.i686.rpm installed from the FC3 testing directory.
Comment 24 Mike Burger 2004-12-17 10:48:39 EST
Running 2.6.9-1.9_FC2, pilot synchronization working for me, too.

Note You need to log in before you can comment on or make changes to this bug.