Bug 140193 - Oops in visor module (2.6.9-1.678_FC3)
Oops in visor module (2.6.9-1.678_FC3)
Status: CLOSED DUPLICATE of bug 140005
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-20 15:43 EST by Pawel Salek
Modified: 2015-01-04 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-21 23:35:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pawel Salek 2004-11-20 15:43:41 EST
Description of problem:
Any attempt to establish a connection with visor leads to a kernel oops:
# pilot-xfer -p /dev/ttyUSB1 -l

visor 1-2:1.0: Handspring Visor / Palm OS converter detected
usb 1-2: Handspring Visor / Palm OS converter now attached to ttyUSB4
usb 1-2: Handspring Visor / Palm OS converter now attached to ttyUSB5
Debug: sleeping function called from invalid context at
include/linux/rwsem.h:43in_atomic():0[expected: 0], irqs_disabled():1
 [<0211c937>] __might_sleep+0x7d/0x8a
 [<0215e42a>] rw_vm+0x216/0x482
 [<22aa706c>] visor_open+0x6c/0x24c [visor]
 [<22aa706c>] visor_open+0x6c/0x24c [visor]
 [<0215eb7c>] get_user_size+0x30/0x57
 [<22aa706c>] visor_open+0x6c/0x24c [visor]
 [<02119299>] __is_prefetch+0x1c2/0x2a7
 [<22aa706c>] visor_open+0x6c/0x24c [visor]
 [<0211937e>] do_page_fault+0x0/0x511
 [<0211937e>] do_page_fault+0x0/0x511
 [<021196a4>] do_page_fault+0x326/0x511
 [<02107f49>] handle_IRQ_event+0x25/0x4f
 [<02108a86>] do_IRQ+0x1ff/0x290
 [<02146cbc>] buffered_rmqueue+0x1dd/0x200
 [<0211937e>] do_page_fault+0x0/0x511
 [<22aa706c>] visor_open+0x6c/0x24c [visor]
 [<22a9f2d5>] serial_open+0x95/0xd9 [usbserial]
 [<0221cd49>] tty_open+0x132/0x360
 [<021702b2>] chrdev_open+0x3bd/0x458
 [<02164882>] dentry_open+0xbd/0x180
 [<021647bf>] filp_open+0x36/0x3c
 [<02164cd5>] sys_open+0x31/0x7d
Unable to handle kernel NULL pointer dereference at virtual address
00000000
 printing eip:
22aa706c
*pde = 00000000
Oops: 0000 [#5]
Modules linked in: visor usbserial radeon md5 ipv6 parport_pc lp
parport i2c_dev i2c_core ipt_REJECT ipt_state iptable_filter
ipt_MASQUERADE iptable_nat ip_conntrack ip_tables dm_mod button
battery ac joydev ohci1394 ieee1394 ehci_hcd uhci_hcd snd_cmipci
snd_pcm_oss snd_mixer_oss snd_pcm snd_page_alloc snd_opl3_lib
snd_timer snd_hwdep gameport snd_mpu401_uart snd_rawmidi
snd_seq_device snd soundcore 8139too mii floppy ext3 jbd
CPU:    0
EIP:    0060:[<22aa706c>]    Not tainted VLI
EFLAGS: 00210002   (2.6.9-1.678_FC3)
EIP is at visor_open+0x6c/0x24c [visor]
eax: 21fd8e00   ebx: 00200202   ecx: 22aaafc0   edx: 117ddc60
esi: 00000000   edi: 21fd8e00   ebp: 20928c20   esp: 1fa84ed0
ds: 007b   es: 007b   ss: 0068
Process pilot-xfer (pid: 9388, threadinfo=1fa84000 task=0fd2cd10)
Stack: 21fd8e00 20928c20 180d3000 00000000 22a9f2d5 117ddc60 ffffffed
117ddc60
       180d3000 00000000 0221cd49 00000802 0bc00005 180d3000 00000005
1fa84000
       21c37204 1671599c 00000000 021702b2 00000000 117ddc60 00000005
117ddc60
Call Trace:
 [<22a9f2d5>] serial_open+0x95/0xd9 [usbserial]
 [<0221cd49>] tty_open+0x132/0x360
 [<021702b2>] chrdev_open+0x3bd/0x458
 [<02164882>] dentry_open+0xbd/0x180
 [<021647bf>] filp_open+0x36/0x3c
 [<02164cd5>] sys_open+0x31/0x7d
Code:  Bad EIP value.

No communication with visor is possible.
Comment 1 Dave Jones 2004-11-21 23:35:04 EST

*** This bug has been marked as a duplicate of 140005 ***

Note You need to log in before you can comment on or make changes to this bug.