Bug 140197 - thunderbird postscript prints outside the margins
Summary: thunderbird postscript prints outside the margins
Status: CLOSED DUPLICATE of bug 140584
Alias: None
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
(Show other bugs)
Version: 3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-20 21:46 UTC by james
Modified: 2007-11-30 22:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-19 17:06:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description james 2004-11-20 21:46:20 UTC
From Bugzilla Helper:
User-Agent: Opera/7.54 (X11; Linux i686; U)  [en]

Description of problem:
When printing an email, the postscript generated by thunderbird does 
not respect the margin settings.  The printed page is cut-off on the 
right side.

Oddly, the print preview looks fine.  Of course, the postscript 
output does not look anything like the print preview.

Version-Release number of selected component (if applicable):
thunderbird-0.9-2

How reproducible:
Always

Steps to Reproduce:
1. click File/Page Setup/Margins & Header/Footer
2. select margins
3. click File/Print.../Print
    

Actual Results:  Text overlaps in places and is cut-off on the right.

Expected Results:  properly rendered postscript

Additional info:

Using ghostscript-7.07-33

Comment 1 Aleksey Nogin 2004-12-16 05:35:07 UTC
I see this too.

Comment 2 Felix Boecker 2004-12-20 23:22:18 UTC
Running Thunderbird 1.0 on FC3 64bit having the same issue although
not only the printer but also the print preview cuts off the right margin.

Comment 3 Michael J. Chudobiak 2005-03-09 12:36:39 UTC
Apparently this only happens for plain text messages using the fixed width font.
The workaround is to set the Plain Text Messages settings in
Edit>Options>Display to Variable Width font. This screws up formatting, but it
prints.

See http://forums.mozillazine.org/viewtopic.php?t=232221 for details.

Comment 4 Michael J. Chudobiak 2005-03-09 21:26:58 UTC
This is listed in the Mozilla Bugzilla also:
http://bugzilla.mozilla.org/show_bug.cgi?id=280059.

The bug seems to be limited to Fedora and Mandrake.

Comment 5 Aleksey Nogin 2005-04-19 17:06:58 UTC
This got fixed by the urw-fonts errata!

*** This bug has been marked as a duplicate of 140584 ***


Note You need to log in before you can comment on or make changes to this bug.