Bug 140204 - unable to install Development Tools from system-config-packages
unable to install Development Tools from system-config-packages
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-packages (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-20 21:44 EST by Andrew D. Stadler
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 15:53:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew D. Stadler 2004-11-20 21:44:58 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/125.5.5 
(KHTML, like Gecko) Safari/125.11

Description of problem:
Fresh install (not upgrade) of FC3 from DVD.  Started with "basic" installation selection, 
worked on boot/config setup issues, and finally ran up2date.  Now it boots properly and 
time to add the usual tools.

$ sudo system-config-packages

Select most other things and able to install no problem.
Select "Development tools" (default configuration) and cannot install due to problems with 
libxml2.  Console error:  ('libxml2', '2.6.16')

Tried downloading libxml2 from fedora, but basic version of libxml is too old, and getting 
it from updates returns same version.

Also tried development tools with all extras "off".

Also tried sudo rpm --rebuilddb

Finally trying, per suggestion in web site, 'sudo yum groupinstall "Development Tools" '  
Don't know yet if it will succeed - it's going to take a while - frustrating to download all 
this stuff that's sitting on my DVD.

Version-Release number of selected component (if applicable):
system-config-packages-1.2.20-1

How reproducible:
Always

Steps to Reproduce:
1.  Fresh install FC3 with "basic" configuration
2.  Run up2date to get latest of stuff
3.  Run system-config-packages and attempt to add Development Tools
    

Actual Results:  should work

Expected Results:  complains about libxml2

Additional info:

Calling this High because linux without gcc & python isn't really useable....
Comment 1 Andrew D. Stadler 2004-11-20 21:46:12 EST
currently installed version of libxml2 is  libxml2-2.6.16-3
Comment 2 Andrew D. Stadler 2004-11-23 14:13:20 EST
update: sudo yum groupinstall "Development Tools" was very very slow, but it worked 
properly.
Comment 3 Paul Bolle 2004-11-29 17:38:49 EST
More or less the same problem here. In my case it complains about
libselinux (for system-config-securitylevel) and libxml2 (for
libxml2-python).

Please note that one can't easily cut and paste the "Unlocatable
package" and "Required By"  entires in the "Packages Not Found" dialog!

These packages seem however to be installed:
rpm -q libxml2 libselinux
libxml2-2.6.16-3
libselinux-1.19.1-8

This I found in the (rather verbose) output of "sudo
system-config-packages" in gnome-terminal:
(...)
selecting already installed package perl-XML-Encoding
* using (...)
* using libselinux-0:1.17.14-1.i386 to satisfy libselinux-1.17.14
* using (...)
* using libxml2-0:2.6.14-2.i386 to satisfy libxml2-2.6.14
* using (...)
('libselinux', '1.19.1-1')
('libxml2', '2.6.16')

I haven't yet tried sudo yum groupinstall "Development Tools"
Comment 4 Torrey Hoffman 2005-01-09 19:53:35 EST
Same problem here on x86.  Did basic install, updates, later tried to
install development tools.  Got a "Packages Not Found" dialog back with:

Unlocatable Package  | Required By
libselinux           | ('system-config-securitylevel', '1.4.18', '2')
krb5-libs            | ('krb5-workstation', '1.3.6', '2')
pam                  | ('sane-backends', '1.0.15', '1.4')
libxml2              | ('libxml2-python', '2.6.16', '3')

I'm trying yum groupinstall "Development Tools" now.  Hope it works.
Comment 5 Aaron Schlaegel 2005-01-13 03:30:41 EST
This is more generally covered in bug 121389
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=121389
Comment 6 morgan read 2005-05-13 03:08:32 EDT
Yup, more or less same as above.  Switched off the Devel Extras - and it said
I've even more "Packages Not Found" (dep's) not installed!!!

So, tip/work-around that's occurred to me on reading Comment #2 above:
-set up a local repo for yum,
-make yourself a mount point in that repo for your fc3 dvd,
-mount your dvd there,
-run createrepo on your local repo (which will descend into any sub-directories)
-run yum as per Comment #2, but from the local repo with your fc3 dvd you've
just set-up

Regards,
morgan.
PS check out yumex.
Comment 7 Jeremy Katz 2005-09-21 15:53:35 EDT
This is caused by updates which s-c-p doesn't know about.  The next generation
of the tool in development for Fedora Core 5 will resolve thsi problem

Note You need to log in before you can comment on or make changes to this bug.