Bug 140215 - RFE: Add the initrd DSDT patch to the official kernel image
RFE: Add the initrd DSDT patch to the official kernel image
Status: CLOSED DUPLICATE of bug 110511
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2004-11-21 00:54 EST by Justin Georgeson
Modified: 2015-01-04 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-11-21 02:43:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Justin Georgeson 2004-11-21 00:54:35 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Many laptops ship with nonstandard DSDTs for ACPI. Looking at
http://gaugusch.at/kernel.shtml one can patch the kernel to include a
custom dsdt in an initrd image. Why not include this kernel patch into
the Fedora kernel image? That way users who patch their DSDT can just
dump it into their existing initrd image and not mess with all the
extra steps one now has to take to build a custom version of the
Fedora patched kernel. You could even add a system-config-dsdt[-tui]
app to add/update the DSDT in the initrd image. It'd be a great step
in enhancing the out-of-the-box ACPI functionality.
Comment 1 Dave Jones 2004-11-21 02:43:58 EST
the acpi code is complex enough that I'd prefer not to deviate away from
mainline at all. Convince the upstream acpi folks to get it into Linus' kernel,
and it'll end up in Fedora next time we rebase.
Comment 2 Charles R. Anderson 2008-06-24 13:43:00 EDT

*** This bug has been marked as a duplicate of 110511 ***

Note You need to log in before you can comment on or make changes to this bug.