Bug 110511 - Load DSDT from initrd
Summary: Load DSDT from initrd
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL: http://gaugusch.at/kernel.shtml
Whiteboard:
Keywords: FutureFeature
: 140215 169014 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-20 16:22 UTC by Péter, Soós
Modified: 2008-06-24 17:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-19 14:35:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This patch make it possible to add DSDT to initrd by mkinitrd (2.81 KB, patch)
2003-11-20 16:24 UTC, Péter, Soós
no flags Details | Diff
The kernel patch to load the DSDT from initrd (for kernel 2.4.22-1.2129) (3.29 KB, patch)
2003-12-08 12:43 UTC, diego.santacruz
no flags Details | Diff

Description Péter, Soós 2003-11-20 16:22:08 UTC
From Bugzilla Helper:
User-Agent: Opera/7.22 (X11; Linux i686; U)  [en]

Description of problem:
The DSDT (Differentiated System Description Table) often needs to be 
overridden because of broken BIOS implementations. If you want to use 
a customized DSDT you have to recompile the whole kernel as described 
on Intel's ACPI pages. But there is a kernel patch to make it 
possible to load DSDT from initial ramdisk (initrd).

Version-Release number of selected component (if applicable):
kernel-2.4.22-1.2115.nptl

Comment 1 Péter, Soós 2003-11-20 16:24:22 UTC
Created attachment 96090 [details]
This patch make it possible to add DSDT to initrd by mkinitrd

Comment 2 diego.santacruz 2003-12-08 12:43:20 UTC
Created attachment 96396 [details]
The kernel patch to load the DSDT from initrd (for kernel 2.4.22-1.2129)

I've been using this patch since long ago and it's really handy.
I've added to the src.rpm of kernel-2.4.22-1.2129 as patch 900 without any
problems.

Comment 3 Péter, Soós 2004-01-19 14:51:25 UTC
The original site of the patch for both 2.4 and 2.6:
http://gaugusch.at/kernel.shtml

Comment 4 Dave Jones 2004-06-19 14:35:16 UTC
I'd much rather see something worked out upstream with the ACPI
maintainers than take some new functionality which may eventually
differ from upstream.


Comment 5 Charles R. Anderson 2008-06-24 17:42:49 UTC
*** Bug 169014 has been marked as a duplicate of this bug. ***

Comment 6 Charles R. Anderson 2008-06-24 17:43:01 UTC
*** Bug 140215 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.