Bug 140237 - Multi-head setup fails
Multi-head setup fails
Status: CLOSED DUPLICATE of bug 136916
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-21 11:37 EST by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-11-21 11:37:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
The system-config-display program fails to generate a multi-head X
configuration.

Version-Release number of selected component (if applicable):
system-config-display-1.0.23-1

How reproducible:
Always

Steps to Reproduce:
1. As root, run system-config-display
2. Select the Dual-head setup tab
3. Check the "Use dual head" option
4. Select a monitor type
5. Click on "OK"

Actual Results:  The program generated a Python traceback.

Expected Results:  A new xorg.conf file should have been generated.

Additional info:

The traceback shows:

# system-config-display
Trying with card: ATI Radeon 9000
in hydrate_second
Traceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 208,
in ok
    primaryPCIBus = "PCI:%d:%d:%d" %
(self.state.get_videocard_PCIBus(), TypeError: int argument required

Here's what "lspci -v" has to say about my display hardware:

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV250
If [Radeon 9000] (rev 01) (prog-if 00 [VGA])
        Subsystem: ATI Technologies Inc: Unknown device 0002
        Flags: bus master, stepping, 66Mhz, medium devsel, latency 64,
IRQ 11
        Memory at f8000000 (32-bit, prefetchable) [size=64M]
        I/O ports at d800 [size=256]
        Memory at e7800000 (32-bit, non-prefetchable) [size=64K]
        Expansion ROM at f7fe0000 [disabled] [size=128K]
        Capabilities: [58] AGP version 2.0
        Capabilities: [50] Power Management version 2

01:00.1 Display controller: ATI Technologies Inc Radeon RV250 [Radeon
9000] (Secondary) (rev 01)
        Subsystem: ATI Technologies Inc: Unknown device 0003
        Flags: bus master, stepping, 66Mhz, medium devsel, latency 64
        Memory at f0000000 (32-bit, prefetchable) [size=64M]
        Memory at e7000000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [50] Power Management version 2
Comment 1 Paul Nasrat 2004-11-22 10:21:00 EST
Please test the update in updates-testing:

system-config-display-1.0.24-1.noarch.rpm
Comment 2 Paul Nasrat 2004-11-22 10:51:24 EST

*** This bug has been marked as a duplicate of 136916 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:07:12 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.