Bug 140269 - Palm m500 usb kernel NULL pointer syncing in gpilotd
Palm m500 usb kernel NULL pointer syncing in gpilotd
Status: CLOSED DUPLICATE of bug 140005
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-21 17:16 EST by Nader Khalid Alzain
Modified: 2015-01-04 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-21 23:35:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nader Khalid Alzain 2004-11-21 17:16:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
1- Contents of /etc/udev/rules.d/11-local.rules:
KERNEL="ttyUSB*", SYSFS{product}="Palm Handheld", MODE="0666",
NAME="%k", SYMLINK="pilot"

2- Device is set to /dev/pilot. The symbolic link is created correctly
when the sync button is pushed:
[nelzein@boraq ~]$ ls -la /dev/pilot
lrwxrwxrwx  1 root root 7 Nov 21 17:04 /dev/pilot -> ttyUSB7
[nelzein@boraq ~]$ ls -la /dev/ttyUSB7
crw-------  1 nelzein uucp 188, 7 Nov 21 17:04 /dev/ttyUSB7

3- Comments:
This bug may be be specific to Pilot Palm m500. Others reported that
Pilot m505 and other versions worked after adding the rule above in 1.

4- Contents of /var/log/messages:
Nov 21 17:04:08 boraq kernel: usb 1-1.1: Handspring Visor / Palm OS
converter now attached to ttyUSB7
Nov 21 17:04:10 boraq kernel: Unable to handle kernel NULL pointer
dereference at virtual address 00000000
Nov 21 17:04:10 boraq kernel:  printing eip:
Nov 21 17:04:10 boraq kernel: 129d706c
Nov 21 17:04:10 boraq kernel: *pde = 00000000
Nov 21 17:04:10 boraq kernel: Oops: 0000 [#4]
Nov 21 17:04:10 boraq kernel: Modules linked in: visor usbserial
parport_pc lp parport autofs4 i2c_dev i2c_core sunrpc dm_mod button
battery ac md5 ipv6 uhci_hcd ehci_hcd snd_via82xx snd_ac97_codec
snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd_page_alloc gameport
snd_mpu401_uart snd_rawmidi snd_seq_device snd soundcore via_rhine mii
floppy ext3 jbd
Nov 21 17:04:10 boraq kernel: CPU:    0
Nov 21 17:04:10 boraq kernel: EIP:    0060:[<129d706c>]    Not tainted VLI
Nov 21 17:04:10 boraq kernel: EFLAGS: 00010006   (2.6.9-1.678_FC3)
Nov 21 17:04:10 boraq kernel: EIP is at visor_open+0x6c/0x24c [visor]
Nov 21 17:04:10 boraq kernel: eax: 11fc1400   ebx: 00000206   ecx:
129dafc0   edx: 04840a80
Nov 21 17:04:10 boraq kernel: esi: 00000000   edi: 11fc1400   ebp:
0419f6c0   esp: 0acf9ed0
Nov 21 17:04:10 boraq kernel: ds: 007b   es: 007b   ss: 0068
Nov 21 17:04:10 boraq kernel: Process gpilotd (pid: 5487,
threadinfo=0acf9000 task=027971f0)
Nov 21 17:04:10 boraq kernel: Stack: 11fc1400 0419f6c0 11f61000
00000000 12c202d5 04840a80 ffffffed 04840a80
Nov 21 17:04:10 boraq kernel:        11f61000 00000000 0221cd49
00000802 0bc00007 11f61000 00000007 0acf9000
Nov 21 17:04:10 boraq kernel:        0e831c04 0d696d8c 00000000
021702b2 00000000 04840a80 00000007 04840a80
Nov 21 17:04:10 boraq kernel: Call Trace:
Nov 21 17:04:10 boraq kernel:  [<12c202d5>] serial_open+0x95/0xd9
[usbserial]
Nov 21 17:04:10 boraq kernel:  [<0221cd49>] tty_open+0x132/0x360
Nov 21 17:04:10 boraq kernel:  [<021702b2>] chrdev_open+0x3bd/0x458
Nov 21 17:04:10 boraq kernel:  [<02164882>] dentry_open+0xbd/0x180
Nov 21 17:04:10 boraq kernel:  [<021647bf>] filp_open+0x36/0x3c
Nov 21 17:04:10 boraq kernel:  [<02164cd5>] sys_open+0x31/0x7d
Nov 21 17:04:10 boraq kernel: Code: <3>Debug: sleeping function called
from invalid context at include/linux/rwsem.h:43
Nov 21 17:04:10 boraq kernel: in_atomic():0[expected: 0],
irqs_disabled():1
Nov 21 17:04:10 boraq kernel:  [<0211c937>] __might_sleep+0x7d/0x8a
Nov 21 17:04:10 boraq kernel:  [<0215e42a>] rw_vm+0x216/0x482
Nov 21 17:04:10 boraq kernel:  [<129d7041>] visor_open+0x41/0x24c [visor]
Nov 21 17:04:10 boraq kernel:  [<129d7041>] visor_open+0x41/0x24c [visor]
Nov 21 17:04:10 boraq kernel:  [<0215eb7c>] get_user_size+0x30/0x57
Nov 21 17:04:10 boraq kernel:  [<129d7041>] visor_open+0x41/0x24c [visor]
Nov 21 17:04:10 boraq kernel:  [<0210682b>] show_registers+0x109/0x15e
Nov 21 17:04:10 boraq kernel:  [<02106a2f>] die+0x14a/0x241
Nov 21 17:04:10 boraq kernel:  [<0211937e>] do_page_fault+0x0/0x511
Nov 21 17:04:10 boraq kernel:  [<0211937e>] do_page_fault+0x0/0x511
Nov 21 17:04:10 boraq kernel:  [<02119733>] do_page_fault+0x3b5/0x511
Nov 21 17:04:10 boraq kernel:  [<129d706c>] visor_open+0x6c/0x24c [visor]
Nov 21 17:04:10 boraq kernel:  [<02181a9e>] __d_lookup+0x13c/0x21b
Nov 21 17:04:10 boraq kernel:  [<02146cbc>] buffered_rmqueue+0x1dd/0x200
Nov 21 17:04:10 boraq kernel:  [<0211937e>] do_page_fault+0x0/0x511
Nov 21 17:04:10 boraq kernel:  [<129d706c>] visor_open+0x6c/0x24c [visor]
Nov 21 17:04:10 boraq kernel:  [<12c202d5>] serial_open+0x95/0xd9
[usbserial]
Nov 21 17:04:10 boraq kernel:  [<0221cd49>] tty_open+0x132/0x360
Nov 21 17:04:10 boraq kernel:  [<021702b2>] chrdev_open+0x3bd/0x458
Nov 21 17:04:10 boraq kernel:  [<02164882>] dentry_open+0xbd/0x180
Nov 21 17:04:10 boraq kernel:  [<021647bf>] filp_open+0x36/0x3c
Nov 21 17:04:10 boraq kernel:  [<02164cd5>] sys_open+0x31/0x7d
Nov 21 17:04:10 boraq kernel:  Bad EIP value.
Nov 21 17:05:19 boraq kernel:  <6>usb 1-1.1: USB disconnect, address 13
Nov 21 17:05:19 boraq kernel: visor 1-1.1:1.0: device disconnected


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. bring up gpilotd applet
2. place the usb Pilot m500 in cradle
3. hit the sync button on pilot
    

Additional info:
Comment 1 Dave Jones 2004-11-21 23:35:13 EST

*** This bug has been marked as a duplicate of 140005 ***

Note You need to log in before you can comment on or make changes to this bug.