Bug 1402860 - fence-rhevm is probably broken against RHV 4
Summary: fence-rhevm is probably broken against RHV 4
Keywords:
Status: CLOSED DUPLICATE of bug 1422499
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: fence-agents
Version: 7.3
Hardware: All
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Oyvind Albrigtsen
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-08 13:35 UTC by Yaniv Kaul
Modified: 2017-04-26 14:58 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-26 14:58:05 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yaniv Kaul 2016-12-08 13:35:29 UTC
Description of problem:
Looking at the source code (https://github.com/ClusterLabs/fence-agents/blob/master/fence/agents/rhevm/fence_rhevm.py ) , it appears it goes to /api and not /engine/api endpoint, so it'll fail against RHV 4.0.x and above.

Comment 3 Marek Grac 2017-02-06 09:09:11 UTC

*** This bug has been marked as a duplicate of bug 1402862 ***

Comment 4 Yaniv Kaul 2017-02-06 13:38:55 UTC
(In reply to Marek Grac from comment #3)
> 
> *** This bug has been marked as a duplicate of bug 1402862 ***

Marek - this bug is a half of a line fix (just change the URL to /engine/api instead of /api )

The other bug require a bit more work.

Comment 5 Marek Grac 2017-02-06 13:40:36 UTC
@Yaniv:

Will /engine/api works will all older versions?

Comment 6 Oved Ourfali 2017-02-06 13:42:29 UTC
To be accurate, it is /ovirt-engine/api

As far as I remember it works in 3.6 and above (maybe also 3.5).
Juan - can you give a more accurate answer about it?

Comment 7 Juan Hernández 2017-02-06 13:58:07 UTC
The recommended URL is /ovirt-engine/api since oVirt/RHV 3.5. Support for just /api was removed in oVirt/RHV 4.0.

Note also that the version of the fence agent included currently in RHEL already includes this patch (which hasn't been merged upstream):

  Explicitly use version 3 of the oVirt API
  https://github.com/ClusterLabs/fence-agents/pull/71

See bug 1287059 for details.

That means that it will already use /ovirt-engine/api by default, unless explicitly given the '--api-path' option with a different value.

Comment 8 Yaniv Kaul 2017-03-07 07:47:45 UTC
Re-opening it, based on comment 7 - /ovirt-engine/api will work with v3.5 and above, so I suggest making this easy fix now, rather than the small rewrite that is needed to happen to v4 API.

Comment 9 Oyvind Albrigtsen 2017-04-26 14:58:05 UTC
This is fixed in bz#1422499.

*** This bug has been marked as a duplicate of bug 1422499 ***


Note You need to log in before you can comment on or make changes to this bug.