Bug 140296 - megaraid_mbox driver loads and cannot see logical drives
megaraid_mbox driver loads and cannot see logical drives
Status: CLOSED DUPLICATE of bug 140115
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
ia32e Linux
medium Severity high
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2004-11-21 23:44 EST by Dave Mull
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-02-16 11:56:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dave Mull 2004-11-21 23:44:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040707 Firefox/0.9.2

Description of problem:
The new megaraid driver fails to see any presented logical drives.
This causes installation to fail on any system using an affected
controller as the boot device. This will affect most all LSI legacy
AMD and LSI controllers - specifically HP NetRAID 1M and LSI MegaRAID
Express 500 controllers have been tested and consistantly display the
same failure. This is NOT firmware related. The latest firmware from
LSI produces the same result. The previous driver used in RHEL3 is
fully capable of using the same presented logical drives without issue.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Boot the installation CD, press enter to install
2. It load the megaraid_mbox driver
3. It displays the message "No hard drives have been found. You
probably need to manually choose device drivers for the installation
to succeed."
4. Select [Yes] to choose a driver
5. The only driver (and supposedly the correct driver) available is
the loaded megaraid_mbox driver.
6. No drives are available to the installer for installation.
Install fails.

Actual Results:  The megaraid_mbox driver cannot see and defined
logical drives and installation fails.

Expected Results:  The expected result would be for the driver to
recognise the presented logical drives and continue installation.

Additional info:

This affects HP NetRAID 1M controllers, LSI MegaRAID Express 500
controllers, and any other OEM versions of these controllers (REF Bug
135484). Other reports indicate this will also affect other LSI legacy
AMD controllers. This issue is firmware independant. Even the latest
firmware from LSI or HP fails to recognise any logical drives with
these controllers.
Comment 5 Tom Coughlan 2005-02-16 11:56:04 EST

*** This bug has been marked as a duplicate of 140115 ***

Note You need to log in before you can comment on or make changes to this bug.