Bug 140115 - Support for CERC ATA100/4ch disabled in the new megaraid_mbox driver
Support for CERC ATA100/4ch disabled in the new megaraid_mbox driver
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
:
: 140296 149161 (view as bug list)
Depends On:
Blocks: 135876
  Show dependency treegraph
 
Reported: 2004-11-19 15:41 EST by Rezwanul Kabir
Modified: 2007-11-30 17:07 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-30 11:29:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rezwanul Kabir 2004-11-19 15:41:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; 
H010818; .NET CLR 1.0.3705)

Description of problem:
New megaraid_mbox driver in RHEL4 Beta2 disables support for the 
following controller:

VID:0x101e
DID:0x1960
SSVID:0x1028
SSID:0x0511
Description: PowerEdge Cost Effective RAID Controller (CERC) 
ATA100/4ch

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.648_EL.src.rpm

How reproducible:
Always

Steps to Reproduce:
1.Install RHEL4 Beta2 on disks connected to a CERC ATA100/4ch 
controller.
2. Installer loads megaraid_mbox driver but when creating partitions 
it gives "no disk found" message . 
3.
    

Actual Results:  Should be able to install on disks connected to CERC 
ATA100/4ch controller.

Additional info:
Comment 4 Jay Turner 2004-11-22 02:24:24 EST
The megaraid driver has been split into two separate drivers with the 2.6.9
kernel, megaraid_mbox and megaraid_mm.  Can you try manually loading the
megaraid_mm module and seeing if that identifies discs on the controller?  Still
sounds like there might be an issue if anaconda is loading the megaraid_mbox
module which then fails to find any drives, so please confirm that's indeed what
is happening.  Thanks.
Comment 5 Matt Domsch 2004-11-22 09:44:58 EST
The problem is that LSI (in conjunction with Dell Storage) decided to
remove PCI IDs from the megaraid_mbox driver without making a
megaraid_legacy driver available which handled the IDs they removed. 
All cards prior to Dell PERC3, which includes the CERC ATA100/4ch have
become unsupported by LSI for RHEL4 and newer, and they wanted to
remove PERC3-series too. :-(

megaraid_mm is the 'management module' portion of the driver, it
doesn't handle any PCI IDs itself.  It's what claims the /dev/megaraid
device node on behalf of any additional drivers (currently only
megaraid_mbox).
Comment 6 Jay Turner 2004-11-22 09:54:03 EST
OK, now I'm confused.  Do we have a problem from Dell's standpoint?  Or is the
megaraid_mbox driver support "OK" for now, in which case this bug can be closed?
Comment 7 Tom Coughlan 2004-11-22 11:39:08 EST
"unsupported by LSI for RHEL4" 

So is this a bug or not?

Set to NEEDINFO. 
Comment 8 Matt Domsch 2004-11-22 12:22:11 EST
We've got a discussion this afternoon with Dell's Storage team that
interacts with LSI.  From an engineering perspective it's NOTABUG, the
driver implements the Dell Storage / LSI approved list of cards for
RHEL4.  However, from a marketing and customer support perspective,
that approved list may need to have this card added back in, in which
case the driver will need to add the ID back also.

I'll leave in NEEDINFO state for another day or two while this gets
resolved internally.
Comment 10 Susan Denham 2004-11-30 09:45:18 EST
Matt:  what happened in the discussion last week with your Storage
folks?   In our estimation, LSI has dropped the ball; have they
explained to you how your older hardware will be supported?  
Comment 11 Matt Domsch 2004-11-30 11:29:23 EST
At this point, neither LSI nor Dell's Storage team will be supporting 
the CERC ATA/100 raid card in RHEL4.  Therefore I'm closing this as 
NOTABUG, it's working as designed per Dell's requirements.

IT54525 is open to track the list of no-longer-supported hardware for 
your release notes.  I added CERC ATA/100 4-channel  to that list.
Comment 12 Tom Coughlan 2005-02-16 11:56:23 EST
*** Bug 140296 has been marked as a duplicate of this bug. ***
Comment 13 Jay Turner 2005-02-19 14:20:33 EST
*** Bug 149161 has been marked as a duplicate of this bug. ***
Comment 14 Richard L. Goerwitz III 2005-02-19 15:08:03 EST
I understand that Dell's storage team isn't supporting the CERT ATA/100 RAID
card, but as noted there are still a lot of units out there that are working
fine in boxes suitable for a broad range of uses.

Trust me, we (Carleton College) buy plenty of Dells for a small college (dozens
of servers a year and I don't want to even think how many desktops).

At the very least, I'd love to see an unsupported old-style megaraid driver made
available so I can use these old boxes to test RHEL 4.0 before we put services
into production.

Note You need to log in before you can comment on or make changes to this bug.