Bug 140306 - Corrupt downloads of FC3 ISO files
Corrupt downloads of FC3 ISO files
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Elliot Lee
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-22 03:26 EST by Jean Thomason
Modified: 2014-03-16 22:50 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-12 15:13:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jean Thomason 2004-11-22 03:26:29 EST
Description of problem: FC3 ISO files are downloaded corrupt no matter
how many different mirrors are used and no matter how many times FC3
is downloaded.  Downloaded FC3 Disk 1 and md5sum matched and burned
perfectly to CD.  Then downloaded FC3 Disk 2 five times from different
mirrors and md5sum did NOT match in all 5 cases and burned to CD and
CD matched perfectly with ISO file on hard drive but md5sum of ISO
file on hard drive did NOT match md5sum of FC3 Disk 2.  Checked with
www.Linuxquestions.org and a large number of people have complained of
corrupt downloads of FC3.  Please check this out.  I have an AMD
Athlon64 3400 CPU with FC2 32-bit version 2.6.5-1.358 kernel.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Download FC3 ISO files
2.Md5sum them and they NEVER match
3.They fail media-check with FC3 Disk 1 and FC2 Disk 1
  
Actual results:
Corrupt ISO files of FC3

Expected results:
All downloads of FC3 ISO files [except Disk 1] are corrupt and fail
md5sum and Install Disk 1's media-check

Additional info:
Comment 1 Sitsofe Wheeler 2004-11-23 02:39:44 EST
This problem could be almost anywhere. The files are probably fine on
the mirrors and things are being corrupted en route. You do not say
whether you are using FTP/HTTP/rsync/bittorrent to download the ISOs.
Nor do you list one of the mirrors you had a corrupt download from.
You may be able to patch up a broken download by using rsync or
bittorrent to refetch only the parts of the files that are corrupt.

(by the way, if the MD5SUMs don't match then it's not even worth
trying to burn the CD)

Just out of interest do you overclock your machine? Have you had any
other trouble with your network connection? Are you using any binary
only drivers? Have you had any hard disk errors?
Comment 2 Se Lee 2004-11-23 18:47:08 EST
I believe I'm experiencing the same issue. Now, I'm glad (?) that I'm 
not the only one. By the way, I think this is the same issue that bug 
#139386 is referring.

Even though I didn't perform the checksum verification (via MD5SUM) 
because I am still using Microsoft OS to download the ISO files, I 
don't think the corruption of ISO file occurred during the 
downloading. I'm afraid that there is a possibility of corruption on 
the original ISO file (on the download site). 

The reason that I'm suggesting such possibility is: 

1. I have downloaded the CD images 4 times already and re-burn the 
images many times over and over, and they are always bad;
 1). Via 'Torrent' over the cable modem connection.
 2). Via 'ftp client' over the cable modem connection from the main 
ftp site.
 3). Via 'Torrent' over the cable modem connection.
 4). Via 'Torrent' over the dsl line connection.

2. However, that the DVD image that I downloaded while using the same 
method that I mentioned above is always good.

Thanks,
Comment 3 Sitsofe Wheeler 2004-11-24 17:04:36 EST
No one mentions WHICH mirrors or WHICH torrents these corrupted files
are on.

Comment #2, it is possible to get get MD5SUM for Windows (e.g. a quick
google turned up
http://downloads.activestate.com/contrib/md5sum/Windows/ ) so you can
quickly check if a download is corrupt or not. With something like
bittorrent makes sure that the download has completely finished
downloading ALL files (not just the first) before trying checking them.

One known good mirror is zeniii.linux.org.uk. If you download the ISOs
from there and find the MD5SUM corrupt then you have reason to suspect
the FTP client you are downloading the ISOs, your connection or
hardware trouble.

I'm not sure that this has anthing to do with the kernel component though.
Comment 4 Se Lee 2004-12-01 16:44:54 EST
Thank you very much for letting me know about the windows version of 
MD5SUM. I guess I didn’t try hard. (I’m also sorry that I didn’t 
specify the location of download and their file names..).

However, MD5SUM gave me more questions than answer… because I got the 
checksum match on all those CD Images that I’ve been having troubles 
with. What does this mean?

Does this mean the bug #106685 (please see comment #16 on it) that 
was reported during fc3-test2/3 is introduced to the final ‘CD’ 
images (FC3-i386-discX.iso)? Like I said, DVD image (FC3-i386-
DVD.iso) works fine.

Does this mean I’m the one of few people still using the CD drive 
instead of DVD drive (and DVD media)?

I think the best approach we (?) can take at this point is ‘a trial 
by another user’. I certainly don’t want to waste developers’ 
valuable time any more, but I can not imagine why only some users 
have this kind of problem and they are getting same result (can not 
install FC3) all the time. So, could anyone try installing FC3 
from ‘FC3-i386-discX’ image and let me know about the result?

By the way, I don’t know why it was assigned to ‘kernel component’. I 
don’t believe I did that.
Comment 5 Sitsofe Wheeler 2004-12-02 05:57:30 EST
Se:
If verifying the disks works when you boot with "linux cddma=off" then yes, you
are seeing 106685. How you burned the disks can also affect whether you bump
into that so that may be why other people haven't seen this problem.

Jean:
Are you still seeing this bug? If so does booting with "linux cddma=off" help?
Comment 6 Brian Pav 2004-12-08 12:59:15 EST
I getting the same media check error on the ISO files. I have
downloaded them from several mirrors in the North East. See list
below. I have currently downloaded and redownloaded the images
appprox. 10 times (that's 6.3gig!!!) I have burn 25 or so costers on
various machines with  Nero, Roxio on WinXP. I have also burned the cd
at a lower speed (x4 on  x36 media). I have also downloaded from
differnt networks ranging from DSL, Cable, and a T3. Nothing!!!!!! 

What is going on!!!! I'm going to switch back to ManDrake If I can't
find an answer.


MIRRORS:
http://download.fedora.redhat.com/
ftp://ftp.linux.ncsu.edu/pub/fedora/linux/core/
ftp://ftp.cse.buffalo.edu/pub/fedora/linux/core/
ftp://mirror.linux.duke.edu/pub/fedora/linux/core/
http://distro.ibiblio.org/pub/linux/distributions/fedora/linux/core/



Comment 7 Robert Becker 2005-04-11 21:00:53 EDT
I am only having a problem with core 3 disc 3.  No matter where I FTP it from 
I get the follwing discrepancy.  

(my md5sum output)
1e95a10df77165dcdab481bde68a4714 *FC3-i386-disc3.iso <-- my results
f88f6ab5947ca41f3cf31db04487279b <--should look this!

I didn't have an issue with the other 3 ISOs.  BTW, my md5sum results have 
been the same for every file I have downloaded.  Why would disc 3 not download 
correctly while the others do?
Comment 8 Dave Jones 2005-04-11 21:05:25 EDT
I see nothing here which indicates this is a kernel problem.
reassigning to distribution.
Comment 9 Robert Becker 2005-04-11 21:08:20 EDT
I know it's a waste of time, but I went ahead and just burned core 3 disc 3 
even with the mismatched md5sum and the media check reported: FAIL!  As 
expected.  
Comment 10 Robert Becker 2005-04-12 02:46:01 EDT
Sorry for the additional confusion to this issue, but I can only get this to 
happen on one PC.  I moved to another machine and all the ISOs downloaded and 
their md5sums were correct and when burned the media passed all four discs 
too.  Both are running WinXP Pro.
Comment 11 Elliot Lee 2005-04-12 15:13:01 EDT
Unfortunately, there doesn't seem to be anything here that can be fixed on this
end. It does sound like something is frustratingly messed up, but the files do
all verify correctly on this end. You may have to avail yourself of the Fedora
support options for help.

Note You need to log in before you can comment on or make changes to this bug.