Bug 140321 - abiword dies when launched with a config file with crazy settings
abiword dies when launched with a config file with crazy settings
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: abiword (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Mike McLean
:
: 105624 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-22 06:02 EST by Sitsofe Wheeler
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.4.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-23 07:49:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Errant abiword profile (634 bytes, text/plain)
2004-11-22 06:05 EST, Sitsofe Wheeler
no flags Details

  None (edit)
Description Sitsofe Wheeler 2004-11-22 06:02:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040804 Galeon/1.3.17

Description of problem:
(This is basically bug 105624 but people claim not to be able to
reproduce it any more)

A user who had migrated from abiword on FC1 was unable to start
abiword under FC3. Closer inspection revealed some kerazee geometry
settings in  ~/.AbiSuite/AbiWord.Profile

Version-Release number of selected component (if applicable):
abiword-2.0.12-4.fc3

How reproducible:
Always

Steps to Reproduce:
1. Copy duff AbiWord.Profile to ~/.AbiSuite/AbiWord.Profile .
2. Start abiword.

Actual Results:
abiword quits immediately. If launched from a terminal the following
is printed:
he program 'AbiWord' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 2514 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error()
function.)

User feels inadequate and blames themselves even though it wasn't
their fault.

Expected Results:
Abiword to work around/detect silly settings and select a sensible
window size and start.

User to moderately happy as everything works as normal. No blame
assignment is done by anyone.

Additional info:

The attached AbiWord.Profile is the smallest version I could make
which still reproduced the error. Deleting the errant lines or moving
the file resolved the problem and allowed abiword to start.

This is probably still bug 105624 /
http://bugzilla.abisource.com/show_bug.cgi?id=5623
Comment 1 Sitsofe Wheeler 2004-11-22 06:05:01 EST
Created attachment 107171 [details]
Errant abiword profile
Comment 2 Caolan McNamara 2004-11-22 08:23:10 EST
Should be easy to fix, 2.2 is out and I'm building that with a fix for
this included as well. So should be good in 2.2.0-1
Comment 3 Caolan McNamara 2004-11-22 08:26:14 EST
Patch also upstreamed as:
http://bugzilla.abisource.com/show_bug.cgi?id=7960
Comment 4 Caolan McNamara 2004-11-23 07:49:07 EST
2.4.0-2 in rawhide fixes this wierdness
Comment 5 Sitsofe Wheeler 2004-11-23 17:22:49 EST
Will this fix (in any shape or form) make its way into FC3?
Comment 6 Caolan McNamara 2004-11-25 04:01:38 EST
Now done as abiword-2.0.12-7.fc3.
Comment 7 Sitsofe Wheeler 2004-11-25 04:51:27 EST
Thanks!
Comment 8 Caolan McNamara 2004-11-25 04:58:46 EST
*** Bug 105624 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.