Bug 140324 - man pages are not in UTF-8.
man pages are not in UTF-8.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: patchutils (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: 139341
  Show dependency treegraph
 
Reported: 2004-11-22 06:07 EST by Miloslav Trmač
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-22 08:01:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloslav Trmač 2004-11-22 06:07:52 EST
The default character set of xmlto for man pages seems to be locale-dependent.
The patchutils-0.2.30 tarball contains man pages in iso-8859-1.

It might be better to run xmlto as (LC_ALL=en_US.UTF-8 xmlto ...)
* to make builds more reproducible
* because UTF-8 is The One Right Encoding (-: and man complains when man pages
  are not in UTF-8.
Comment 1 Tim Waugh 2004-11-22 08:01:49 EST
The problem was in docbook-style-xsl.  Fixed in docbook-style-xsl-1.67.0-3 and
patchutils-0.2.30-3.

Note You need to log in before you can comment on or make changes to this bug.