Bug 139341 - Might want to check correct encoding of man-pages?
Summary: Might want to check correct encoding of man-pages?
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Bill Nottingham
URL:
Whiteboard:
Keywords: i18n
Depends On: 140173 140195 140318 140324 140512 140518 140707 140945 140946
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-15 13:59 UTC by Florian La Roche
Modified: 2014-03-17 02:50 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-03 22:41:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Florian La Roche 2004-11-15 13:59:14 UTC
Description of problem:


/usr/share/man> for x in `find -name *gz`; do zcat $x | if ! test -z
"`iconv 2>&1 >/dev/null`"; then echo $x; fi  done
./man1/ptx.1.gz
./man1/perlcn.1.gz
./man1/perlebcdic.1.gz
./man1/perlhack.1.gz
./man1/perlhist.1.gz
./man1/perljp.1.gz
./man1/perlko.1.gz
./man1/perlothrtut.1.gz
./man1/perlthrtut.1.gz
./man1/perltw.1.gz
./man1/fc-cache.1.gz
./man1/fc-list.1.gz
./man1/grolbp.1.gz
./man1/gs-pcl3.1.gz
./man1/pcl3opts.1.gz
./man1/ntpdate.1.gz
./man1/ntpq.1.gz
./man1/tickadj.1.gz
./man1/cdrecord.1.gz
./man1/mkromdic.1.gz
./man1/ppmshadow.1.gz
./man1/flipdiff.1.gz
./man1/unwrapdiff.1.gz
./man1/dvdrecord.1.gz
./man3/Unicode::Collate.3pm.gz
./man5/sane-agfafocus.5.gz
./man5/sane-avision.5.gz
./man5/sane-coolscan2.5.gz
./man5/sane-umax_pp.5.gz
./man7/groff_mm.7.gz
./man7/groff_mmse.7.gz
./man8/netdump-server.8.gz


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Eido Inoue 2004-11-22 08:28:58 UTC
It should be noted that recent versions of man should be able to
handle non-UTF-8 man-pages (for the sake of 3rd party cross-distro
rpms)... although man assumes that each language is either UTF-8 or
exactly one other predetermined encoding (example: Russian is KOI8-R
if it's not UTF-8). The "other" encoding is what I believed to be the
"most popular" encoding in Linux for that language's man pages.

Where this runs into trouble is for languages with multiple encodings;
e.g. French (ISO-8859-1 and ISO-8859-15), Japanese (EUC-JP,
ISO-2022-JP, and (rarely) Shift-JIS). These two languages deserve
special attention with respect to multiple charsets/encodings.

Comment 2 Jindrich Novy 2004-11-22 08:52:32 UTC
Adrian, because of the reason you presented I convert all the man
pages in packages where I found bad encoded man to UTF-8. Do you have
any objections against that?

Florian, we're working together with mitr to convert all the pages to
the correct enoding. On my fresh FC3 installation I've found slighly
more that 100 man pages in wrong encoding.

Comment 3 Eido Inoue 2004-11-22 09:05:03 UTC
Comment 2: absolutely no objections-- thanks Jindrich. The intention
for the non-UTF-8 support is for supporting LEGACY/old man-pages from
3rd party folks playing catch up.

(It will print a warning to stderr when man encounters a non-UTF-8 pages)

Comment 4 Miloslav Trmač 2004-12-03 22:41:36 UTC
All packages except the blockers of this bug have been fixed.


Note You need to log in before you can comment on or make changes to this bug.