This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 140329 - Duplicate ext3 label created while installing to multiple disks
Duplicate ext3 label created while installing to multiple disks
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
:
: 145082 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-22 07:18 EST by Bob Allison
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2005-192
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-05 12:26:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bob Allison 2004-11-22 07:18:17 EST
Description of problem:
I am installing Fedora Core 3 to a machine with one IDE drive and one
SCSI drive (hda and sda).  I am doing a reinstall of the entire system
using kickstart (all partitions on both drives removed and rebuilt).

The IDE drive get partitions hda1 (ext3, /boot) and hda2 (LVM).  The
SCSI drive gets partition sda1 (LVM).  The partitions get created, the
filesystems get formatted, and the installation works just fine.

When the system reboots afterwards, I get the message "mount:
LABEL=/boot duplicate - not mounted".  It turns out that hda1 and sda1
are both labelled as /boot.


Version-Release number of selected component (if applicable):


How reproducible: Every time I re-install this system


Steps to Reproduce:
1. Re-install system
2. Reboot
  
Actual results:
Error mounting /boot

Expected results:
/boot mounted

Additional info:
Comment 1 Jeremy Katz 2004-11-22 11:23:15 EST
This is because the pvcreate on sda1 isn't wiping out the ext3 metadata.
Comment 2 Bob Allison 2004-11-22 11:37:05 EST
I assume that "dd if=/dev/zero of=/dev/sda bs=1024 count=?" will clear
this out to eliminate the message, but how much so I need to clear?
Comment 3 Alasdair Kergon 2004-12-21 12:11:33 EST
So pvcreate needs to check for this and optionally wipe it.
Comment 4 Alasdair Kergon 2005-01-05 11:15:13 EST
Suggest we add the -Z option to pvcreate [like lvcreate], with default
value 'yes' unless 'restorefile' or 'uuid' are specified.
Comment 5 Alasdair Kergon 2005-01-05 12:26:14 EST
In CVS, will get rolled up into next release.
Comment 6 Alasdair Kergon 2005-01-05 12:31:00 EST
BTW the ext label to wipe is in sector 2 ie wipe 512 bytes at 1024
Comment 7 Alasdair Kergon 2005-01-13 18:30:43 EST
*** Bug 144827 has been marked as a duplicate of this bug. ***
Comment 8 Alasdair Kergon 2005-01-14 05:02:31 EST
*** Bug 145082 has been marked as a duplicate of this bug. ***
Comment 9 Tim Powers 2005-06-09 08:29:57 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-192.html

Note You need to log in before you can comment on or make changes to this bug.