Bug 145082 - lvm2 doesn't clear all filesystem metadata
Summary: lvm2 doesn't clear all filesystem metadata
Status: CLOSED DUPLICATE of bug 140329
Alias: None
Product: Fedora
Classification: Fedora
Component: lvm2   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Alasdair Kergon
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-14 07:11 UTC by Bill Nottingham
Modified: 2014-03-17 02:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-27 17:36:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Nottingham 2005-01-14 07:11:25 UTC
Create a RAID-1 array, md0. Then do the following:

mke2fs /dev/md0
e2label /dev/md0 foo
add to /etc/fstab:
 LABEL=foo /misc ext3 defaults 1 1
mount /misc
<look at filesystem>

umount /misc
pvcreate /dev/md0
vgcreate wibble /dev/md0
lvcreate --size=<whatever> -name wow bar
mke2fs /dev/bar/wow
e2label /dev/bar/wow foo

Then:

# mount /misc
mount: error: the label foo occurs on both md0 and dm-0

Shouldn't making the LVM volume get rid of the old filesystem label
somehow?  You can always run 'e2label /dev/md0 ""' to delete the
label, but running that on the the raw RAID volume under the LVM seems
unwise.

Comment 1 Alasdair Kergon 2005-01-14 10:02:19 UTC

*** This bug has been marked as a duplicate of 140329 ***


Note You need to log in before you can comment on or make changes to this bug.