Bug 140333 - spamassassin 3 should not irreversibly migrate bayes database
spamassassin 3 should not irreversibly migrate bayes database
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: spamassassin (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-22 08:18 EST by Sitsofe Wheeler
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-03 06:36:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sitsofe Wheeler 2004-11-22 08:18:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040804 Galeon/1.3.17

Description of problem:
While reproducing bug 139834, my bayes learning was migrated to
spamassassin 3 format. However, my home directory is shared by a
machine still running spamassassin 2.x. The updated bayes database
drove spamassassin 2.x mad, sending it to an infinitely loop and
filling up the logs. The only recourse was to "throw away" the updated
bayes database (because there was no way to migrate it back into a 2.x
format) thus destroying 2 years of email training and causing spam to
get through.

Version-Release number of selected component (if applicable):
spamassassin-3.0.0-3

How reproducible:
Always

Steps to Reproduce:
(with an existing spamassassin 2.x bayes database / settings)
1. Run sa-learn --sync on a machinen with spamassassin 3.x

Actual Results:
The bayes database is irreversibly changed to 3.x format.

Expected Results:
2.x style bayes to be backed up or 3.x to migrate settings into a
different place and default to using the new settings.

Additional info:
The 2.x spamd wound up printing the following over and over in the
logs until it was killed when using the new format bayes database:

spamd[18068]: Use of uninitialized value in numeric eq (==) at
/usr/lib/perl5/vendor_perl/5.8.1/Mail/SpamAssassin/BayesStore.pm line
1459, <GEN25343> line 56.
Comment 1 Warren Togami 2005-04-03 06:36:32 EDT
Sorry, this is not something that we can fix.  You must convince the upstream
developers if you want real solution.

Note You need to log in before you can comment on or make changes to this bug.