Bug 14035 - "Data integrity error when decompressing" with bzip2-1.0.1-1
Summary: "Data integrity error when decompressing" with bzip2-1.0.1-1
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: bzip2   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-07-15 15:56 UTC by Accot, Johnny
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-15 15:56:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Accot, Johnny 2000-07-15 15:56:25 UTC
Seems as if bzip2-1.0.1 is broken (not only redhat's package, but also with
PLD's
package at ftp.pld.org.pl/stable/i686/bzip2-1.0.1-1.i686.rpm).  It often
finds data
integrity errors in packages where there are obviously no such errors. In
particular,
uncompressing linux-2.4.0-test4.tar.bz2 from ftp.kernel.org gives:

[accot@obane src]$ bunzip2 -tvv linux-2.4.0-test4.tar.bz2
  linux-2.4.0-test4.tar.bz2: 
    [1: huff+mtf rt+rld]
    [2: huff+mtf rt+rld]
    [3: huff+mtf rt+rld]
    [4: huff+mtf rt+rld]
    [5: huff+mtf rt+rld]
    [6: huff+mtf rt+rld]
    [7: huff+mtf data integrity (CRC) error in data

But I noticed the same problem with some of my own archives.

Finally, bzip2-0.9.5d-3 from rawhide-release-20000424 does not find
anything wrong with these archives.

Comment 1 Trond Eivind Glomsrxd 2000-07-17 20:08:58 UTC
I can't reproduce this with current versions (2.4.0test4 kernel, bzip2-1.0.1-2)

Comment 2 Accot, Johnny 2000-07-18 11:23:40 UTC
I can't reproduce it either.  That's weird.  Must have to do
with some libraries I upgraded since (or kernel, since no new
rawhide was released since).  Sorry for the lost time.. :-/


Note You need to log in before you can comment on or make changes to this bug.