Bug 140357 - prelink damages libdbus shared objects
prelink damages libdbus shared objects
Status: CLOSED DUPLICATE of bug 140081
Product: Fedora
Classification: Fedora
Component: prelink (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Depends On:
  Show dependency treegraph
Reported: 2004-11-22 11:18 EST by Stephen Adler
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-11-22 12:30:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Stephen Adler 2004-11-22 11:18:11 EST
Description of problem:

hald does not start up.

Version-Release number of selected component (if applicable):

How reproducible:

every time

Steps to Reproduce:
1. I got my system into some kind of state.. don't know how
2. so to reproduce.. all I have to do is reboot...
3. and watch hald not start...
Actual results:

Expected results:

Additional info:

I did an strace of hald it and it looks like its core
dumping or seg faulting when it tries to read or
write to the system message bus pipe. /var/run/dbug/system_bus_socket.

I'll be glad to run any tests on my system you like.
Comment 1 David Zeuthen 2004-11-22 11:24:11 EST

I've seen bugs like this earlier; my suspicion is that prelink makes
the libdbus libraries not work. Please try this as root

 tar cfv /root/old-dbus-so.tar /usr/lib/libdbus-*.so*
 sudo /usr/sbin/prelink /usr/lib/libdbus-*.so*

and see if that works?
Comment 2 David Zeuthen 2004-11-22 11:28:29 EST
Whoops, drop the sudo before prelink; sorry my bad. Should be this

 tar cfv /root/old-dbus-so.tar /usr/lib/libdbus-*.so*
 sudo /usr/sbin/prelink /usr/lib/libdbus-*.so*
Comment 3 David Zeuthen 2004-11-22 11:29:34 EST
this is the commands to issue as root (I need some coffee :-)):

 tar cfv /root/old-dbus-so.tar /usr/lib/libdbus-*.so*
 /usr/sbin/prelink /usr/lib/libdbus-*.so*

Comment 4 Stephen Adler 2004-11-22 11:47:48 EST
dude! good job.. fixed the problem.. now how come I had to
re-prelink the library files? how did I screw them up? any
Comment 5 David Zeuthen 2004-11-22 11:54:00 EST
This looks to me like a prelink bug - reassigning.
Comment 6 Jakub Jelinek 2004-11-22 12:30:08 EST

*** This bug has been marked as a duplicate of 140081 ***

Note You need to log in before you can comment on or make changes to this bug.