Bug 1403897 - ocamlfind takes forever to link certain libraries
Summary: ocamlfind takes forever to link certain libraries
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ocaml-findlib
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: 7.4
Assignee: Richard W.M. Jones
QA Contact: qe-baseos-tools
URL:
Whiteboard:
: 1409309 (view as bug list)
Depends On: 1384533
Blocks: TRACKER-bugs-affecting-libguestfs
TreeView+ depends on / blocked
 
Reported: 2016-12-12 15:15 UTC by Richard W.M. Jones
Modified: 2017-08-01 18:15 UTC (History)
4 users (show)

Fixed In Version: ocaml-findlib-1.3.3-7.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 18:15:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1926 normal SHIPPED_LIVE ocaml-findlib bug fix update 2017-08-01 18:07:28 UTC

Description Richard W.M. Jones 2016-12-12 15:15:01 UTC
Description of problem:

ocamlfind has a known bug in the version we ship on RHEL 7.3 where
it takes forever to link certain libraries.

This is fixed in the next upstream release in:

  https://gitlab.camlcity.org/gerd/lib-findlib/commit/d5838369130057d207a8140c426d0394989951f2

The release notes say:

   Fixed performance bug when many arguments need to be processed (Jérôme 
   Vouillon).

Version-Release number of selected component (if applicable):

ocaml-findlib-1.3.3-6.el7.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Compile libguestfs >= 1.34 from source.

Actual results:

It will take an hour or so to compile in the mllib/ subdirectory.

Expected results:

It should run very quickly, in not more than a second.

Comment 2 Richard W.M. Jones 2016-12-31 22:03:55 UTC
*** Bug 1409309 has been marked as a duplicate of this bug. ***

Comment 4 Richard W.M. Jones 2017-02-07 09:02:29 UTC
I put fixed packages here for anyone else annoyed by this bug:

http://oirase.annexia.org/tmp/bz1403897/

Comment 5 Richard W.M. Jones 2017-02-07 11:26:54 UTC
Reproducer / verifier:

$ rm test.*
$ touch test.c
$ gcc -c test.c
$ ocamlfind mklib -o testlib test.o test.o test.o test.o test.o test.o test.o test.o test.o test.o test.o test.o test.o test.o test.o test.o test.o test.o test.o test.o test.o test.o test.o test.o test.o test.o test.o test.o test.o test.o test.o test.o test.o test.o test.o test.o test.o

If the bug exists, the final command will sit there for several minutes
using 100% CPU.

If the bug is fixed, the final command will run almost instantly.

Comment 8 errata-xmlrpc 2017-08-01 18:15:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1926


Note You need to log in before you can comment on or make changes to this bug.