Bug 1409309 - Make Stuck for libguestfs-1.34.3 as well as libguestfs-1.35.19 on CentOS Linux release 7.3.1611 (Core)
Summary: Make Stuck for libguestfs-1.34.3 as well as libguestfs-1.35.19 on CentOS Lin...
Keywords:
Status: CLOSED DUPLICATE of bug 1403897
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libguestfs
Version: unspecified
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-31 13:27 UTC by ameya
Modified: 2016-12-31 22:03 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-31 22:03:55 UTC


Attachments (Terms of Use)

Description ameya 2016-12-31 13:27:30 UTC
Description of problem:
I am trying to compile libguestfs on CentOS Linux release 7.3.1611 (Core) using-a-prebuilt-binary-appliance.  Make gets Stuck on

ocamlfind mklib -package str,unix -I ../src/.libs -I ../gnulib/lib/.libs -I ../ocaml -I . -package gettext-stub \
    guestfs_config.cmx ../mllib/bytes.cmx libdir.cmx stringMap.cmx common_gettext.cmx getopt.cmx dev_t.cmx common_utils.cmx fsync.cmx progress.cmx URI.cmx mkdtemp.cmx visit.cmx fnmatch.cmx planner.cmx regedit.cmx StatVFS.cmx JSON.cmx curl.cmx exit.cmx checksums.cmx ../cat/libmllib_a-visit.o ../fish/libmllib_a-decrypt.o ../fish/libmllib_a-keys.o ../fish/libmllib_a-progress.o ../fish/libmllib_a-uri.o libmllib_a-common_utils-c.o libmllib_a-dev_t-c.o libmllib_a-exit-c.o libmllib_a-fnmatch-c.o libmllib_a-fsync-c.o libmllib_a-getopt-c.o libmllib_a-mkdtemp-c.o libmllib_a-progress-c.o libmllib_a-statvfs-c.o libmllib_a-uri-c.o libmllib_a-visit-c.o -o mllib

Version-Release number of selected component (if applicable):
libguestfs-1.34.3 as well as libguestfs-1.35.1 

How reproducible:
./configure --prefix=/usr/local/virtualizor-bin/ --disable-appliance --disable-daemon
make 

Steps to Reproduce:
1../configure --prefix=/usr/local/virtualizor-bin/ --disable-appliance --disable-daemon
2.make 
3.

Actual results:
ocamlfind mklib -package str,unix -I ../src/.libs -I ../gnulib/lib/.libs -I ../ocaml -I . -package gettext-stub \
    guestfs_config.cmx ../mllib/bytes.cmx libdir.cmx stringMap.cmx common_gettext.cmx getopt.cmx dev_t.cmx common_utils.cmx fsync.cmx progress.cmx URI.cmx mkdtemp.cmx visit.cmx fnmatch.cmx planner.cmx regedit.cmx StatVFS.cmx JSON.cmx curl.cmx exit.cmx checksums.cmx ../cat/libmllib_a-visit.o ../fish/libmllib_a-decrypt.o ../fish/libmllib_a-keys.o ../fish/libmllib_a-progress.o ../fish/libmllib_a-uri.o libmllib_a-common_utils-c.o libmllib_a-dev_t-c.o libmllib_a-exit-c.o libmllib_a-fnmatch-c.o libmllib_a-fsync-c.o libmllib_a-getopt-c.o libmllib_a-mkdtemp-c.o libmllib_a-progress-c.o libmllib_a-statvfs-c.o libmllib_a-uri-c.o libmllib_a-visit-c.o -o mllib

Expected results:


Additional info:

Comment 1 Richard W.M. Jones 2016-12-31 22:03:55 UTC
This is actually a bug in ocamlfind.  It's super-annoying, but
if you simply let the build continue then (eventually) it will
complete.

*** This bug has been marked as a duplicate of bug 1403897 ***


Note You need to log in before you can comment on or make changes to this bug.