Bug 140498 - Caught a segmentation fault while loading plugin file: /usr/lib/gstreamer-0.8/libgstalsa.so
Caught a segmentation fault while loading plugin file: /usr/lib/gstreamer-0.8...
Status: CLOSED DUPLICATE of bug 140081
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-22 23:09 EST by JF
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JF 2004-11-22 23:09:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Recently all of sudden on login to Gnome I started getting messages of
"eggcups can't start" and "gnome-volume-manager" can't start. I don't
know if these are related, but the first time I saw these error I got
a message error about gnome-volume-control applet crashing. Then it
asked me if I wanted to try reloading the applet, I said yes but I had
no luck. Then I tried to load gnome-volume-manager from a terminal, it
give me the following message when I try to load it:

gnome-volume-control

ERROR: Caught a segmentation fault while loading plugin file:
/usr/lib/gstreamer-0.8/libgstalsa.so

Please either:
- remove it and restart.
- run with --gst-disable-segtrap and debug.

This is bizzare, and I'm sure why this is happening. Help!

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Not sure what caused the crashing in the first place, used to work fine
2.
3.
    

Additional info:
Comment 1 Colin Walters 2004-11-22 23:16:05 EST
Try running prelink on it:

prelink /usr/lib/gstreamer-0.8/libgstalsa.so
(as root)
Comment 2 JF 2004-11-23 00:26:00 EST
I ran prelink as you suggested and not gnome-volume-control works
properly. Do I have to do this each time I restart or should it be
okay now? Would this be a result of installing packages like
rhythmbox-xine and totem-xine from freshrpms? Cause this seemed to
have started happening after I installed those packages. I also
upgraded the kernel around that time so maybe that caused some things
to be unlinked (?). Weird. Thanks for the fix!
Comment 3 JF 2004-11-23 00:27:11 EST
Sorry, I meant gnome-volume control works properly now (not not as I
said above).
Comment 4 Colin Walters 2004-11-23 00:32:46 EST
It's a prelink bug, hopefully an update will come out soon.


*** This bug has been marked as a duplicate of 140081 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:07:14 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.