This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 140505 - up2date crashes when solving dependencies
up2date crashes when solving dependencies
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
: 140599 140850 141559 (view as bug list)
Depends On:
Blocks: 135876
  Show dependency treegraph
 
Reported: 2004-11-23 01:41 EST by David Jericho
Modified: 2007-11-30 17:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-04 13:21:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jericho 2004-11-23 01:41:48 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
When using up2date to install extra packages, if depenencies are
required up2date crashes with a trackback. Sample trackback is
included below in additional information.

If I manually look up the dependancy list elsewhere, and install each
of those by hand either one by one or on the same command line, no
error occurs.

Version-Release number of selected component (if applicable):
up2date-4.3.53-1

How reproducible:
Always

Steps to Reproduce:
1. rpm -e libstdc++-devel gcc-c++
2. /usr/sbin/up2date gcc-c++


    

Actual Results:  Up2date crashed with a traceback displayed.

Additional info:

Name                                    Version        Rel
----------------------------------------------------------
gcc-c++                                 3.4.2          6.fc3         
   x86_64


Testing package set / solving RPM inter-dependencies...

Downloading headers to solve dependencies...
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1245, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 800, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1119, in batchRun
    batch.run()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 74, in run
    self.__dryRun()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 159, in
__dryRun
    self.percentCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 386, in dryRun
    ret = depsolve.solvedep()
  File "/usr/share/rhn/up2date_client/depSolver.py", line 553, in solvedep
    ret = self.process_deps(deps)
  File "/usr/share/rhn/up2date_client/depSolver.py", line 520, in
process_deps
    changed = self.__dependencies(dependencies)
  File "/usr/share/rhn/up2date_client/depSolver.py", line 307, in
__dependencies
    msgCallback = self.msgCallback)
  File "/usr/share/rhn/up2date_client/depSolver.py", line 93, in solveDep
    msgCallback = msgCallback)
  File
"/usr/share/rhn/up2date_client/repoBackends/genericSolveDep.py", line
44, in solveDep
    msgCallback = self.msgCallback)
TypeError: getSolutions() got an unexpected keyword argument
'progressCallback'
Comment 1 Adrian Likins 2004-11-23 13:57:14 EST
fixed in 4.3.65
Comment 2 Jay Turner 2004-11-24 06:04:44 EST
*** Bug 140599 has been marked as a duplicate of this bug. ***
Comment 4 Adrian Likins 2004-11-24 18:41:07 EST
what version of openssl is installed?

Comment 5 David Jericho 2004-11-24 20:11:24 EST
As of now, openssl-0.9.7a-40
Comment 6 Jay Turner 2004-11-25 03:44:18 EST
Adrian, openssl-0.9.7a-39.  I've been able to reproduce the failure for a number
of different packages (that is, attempting to download the subpackage fails, but
attempting to download the main package succeeds and pulls in the subpackage.)
Comment 7 Jay Turner 2004-11-25 15:10:39 EST
*** Bug 140850 has been marked as a duplicate of this bug. ***
Comment 8 Adrian Likins 2004-11-29 11:22:31 EST
re comment #6, any info about which packages it fails on 
would be appreciated since I'm not seeing it with openssl
Comment 9 Adrian Likins 2004-11-29 12:16:07 EST
nevermind, I see the bug now... bleah, totally broken.
testing a fix at the moment.
Comment 10 Adrian Likins 2004-11-29 15:15:54 EST
fix in up2date-4.3.68
Comment 11 Adrian Likins 2004-12-01 15:52:59 EST
and for what it's worth, I have what I belive to be a
a better fix for this and several other multilib related
dep issues/bugs/kluges/etc. I'm testing it for regression
now in case I get a chance to rev again
Comment 12 Jay Turner 2004-12-02 03:49:07 EST
*** Bug 141559 has been marked as a duplicate of this bug. ***
Comment 13 Jay Turner 2004-12-04 13:21:18 EST
up2date-4.3.68-1 appears to be working pretty well in this area, so closing out
this bug as it's included in the latest RHEL4 trees already.

Note You need to log in before you can comment on or make changes to this bug.