Bug 1405098 - Ocata requires additional cellvs2 setup
Summary: Ocata requires additional cellvs2 setup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: beta
: 11.0 (Ocata)
Assignee: Ollie Walsh
QA Contact: Prasanth Anbalagan
URL:
Whiteboard:
: 1418907 (view as bug list)
Depends On:
Blocks: 1427457
TreeView+ depends on / blocked
 
Reported: 2016-12-15 15:20 UTC by Dan Smith
Modified: 2019-09-09 17:06 UTC (History)
25 users (show)

Fixed In Version: openstack-tripleo-heat-templates-6.0.0-0.20170218023452.edbaaa9.el7ost.noarch.rpm
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 19:51:22 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 405241 None None None 2017-01-30 19:18:59 UTC
OpenStack gerrit 410324 None None None 2017-01-04 14:15:28 UTC
Launchpad 1649341 None None None 2016-12-15 16:27:28 UTC

Comment 1 Stephen Gordon 2016-12-21 20:39:19 UTC
Scott you didn't ask a question?

Comment 4 melanie witt 2017-01-07 02:22:59 UTC
To summarize the release notes:

For an upgrade to Ocata of a non-cells deployment, the following steps are needed in Newton:

1. Create a new database for cell0 based on the current name of the api database: <API database name>_cell0. If the api database is named nova_api, then the cell0 database should be named nova_api_cell0.

2. Run the simple cell setup command: nova-manage cell_v2 simple_cell_setup --transport-url <transport url for message queue>.


An upgrade of an existing cells v1 deployment requires different, more complex steps, so let us know if that info is needed.

There's also an enhancement to the simple_cell_setup command in Ocata that can pick up [DEFAULT]/transport_url from the nova.conf (instead of only the command line), so I'm going to try to get that backported to Newton for use. I will update here if that happens.

Comment 16 Stephen Gordon 2017-02-03 21:24:31 UTC
*** Bug 1418907 has been marked as a duplicate of this bug. ***

Comment 17 Lukas Ruzicka 2017-02-09 12:13:56 UTC
Hello, could you please provide more info about this bug. Is it going to be a part of OSP 11 or not? It would help me to decide how I will handle the documentation for this issue. Thanks a lot.

Comment 18 Stephen Gordon 2017-02-09 12:43:20 UTC
(In reply to Lukas Ruzicka from comment #17)
> Hello, could you please provide more info about this bug. Is it going to be
> a part of OSP 11 or not? It would help me to decide how I will handle the
> documentation for this issue. Thanks a lot.

RHOSP 11 will deploy a so called "cell of one", a single cell deployment. This is because this is mandatory for Nova from Ocata and beyond. This is mostly plumbing from a user perspective, but should be reflected in any manual configuration or architecture documentation so that they are able to understand what is being deployed.

Deployment and configuration of multi-cell environments is not addressed in this release.

Comment 19 Ollie Walsh 2017-02-09 20:52:23 UTC
There will be no manual configuration required. OSPD will deploy a single cell setup for a fresh install or upgrade RHOSP 10 to a single cell.

Upstream docs describe the architecture quite well IMO:
http://docs.openstack.org/developer/nova/cells.html#cells-v2

Comment 20 Stephen Gordon 2017-02-09 20:55:40 UTC
By manual configuration I was referring to the fact that in addition to the director-based installation documentation the docs folks maintain these guides which will likely need updates:

Architecture Guide

https://access.redhat.com/documentation/en/red-hat-openstack-platform/10/paged/architecture-guide/

Manual Installation Procedures

https://access.redhat.com/documentation/en/red-hat-openstack-platform/10/paged/manual-installation-procedures/chapter-8-install-the-compute-service

Comment 21 Lukas Ruzicka 2017-02-10 09:29:46 UTC
Thanks, guys, for your quick reply. I highly appreciate that.

Comment 22 Ollie Walsh 2017-02-10 10:59:38 UTC
Ah, ok. The manual setup procedures will need to be updated for both cell_v2 setup and the placement api setup.

Comment 23 Stephen Gordon 2017-02-22 12:59:34 UTC
Can this be moved to POST or MODIFIED?

Comment 24 Ollie Walsh 2017-03-02 21:16:42 UTC
Greenfield install implemented in numerous upstream patches:
https://review.openstack.org/#/q/topic:bug/1649341

10 -> 11 Upgrade implemented in https://review.openstack.org/405241

Comment 29 errata-xmlrpc 2017-05-17 19:51:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.