Bug 1418907 - openstack-nova: The launched instance doesn't appear in the output from "openstack server list" nor "nova list" [NEEDINFO]
Summary: openstack-nova: The launched instance doesn't appear in the output from "open...
Keywords:
Status: CLOSED DUPLICATE of bug 1405098
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ga
: 11.0 (Ocata)
Assignee: Eoghan Glynn
QA Contact: Prasanth Anbalagan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-03 05:21 UTC by Alexander Chuzhoy
Modified: 2019-09-09 14:42 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-03 21:24:31 UTC
Target Upstream Version:
sasha: needinfo? (dasmith)


Attachments (Terms of Use)

Description Alexander Chuzhoy 2017-02-03 05:21:12 UTC
openstack-nova: The launched instance doesn't appear in the output from "openstack server list" nor "nova list"
Environment:
openstack-nova-api-15.0.0-0.20170127054753.796ea16.el7ost.noarch
openstack-nova-conductor-15.0.0-0.20170127054753.796ea16.el7ost.noarch
python-nova-15.0.0-0.20170127054753.796ea16.el7ost.noarch
openstack-puppet-modules-9.4.0-0.20170111174831.8c758d6.el7ost.noarch
instack-undercloud-6.0.0-0.20170127055514.317db76.el7ost.noarch
openstack-nova-placement-api-15.0.0-0.20170127054753.796ea16.el7ost.noarch
openstack-nova-common-15.0.0-0.20170127054753.796ea16.el7ost.noarch
openstack-tripleo-heat-templates-6.0.0-0.20170127041112.ce54697.el7ost.1.noarch
openstack-nova-scheduler-15.0.0-0.20170127054753.796ea16.el7ost.noarch
puppet-nova-10.2.0-0.20170126233443.cee64d8.el7ost.noarch
openstack-nova-cert-15.0.0-0.20170127054753.796ea16.el7ost.noarch
openstack-nova-compute-15.0.0-0.20170127054753.796ea16.el7ost.noarch
python-novaclient-6.0.0-0.20170125112000.25117fa.el7ost.noarch


Steps to reproduce:
Deploy overcloud with:
openstack overcloud deploy --debug --templates --libvirt-type kvm -e /usr/share/openstack-tripleo-heat-templates/environments/puppet-pacemaker.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e virt/ceph.yaml -e virt/hostnames.yml -e virt/network/network-environment.yaml -e scale.yaml -e vxlan_args_osp11 --log-file overcloud_deployment_48.log

[stack@undercloud-0 ~]$ cat scale.yaml vxlan_args_osp11 
parameter_defaults:
  NtpServer: ["clock.redhat.com","clock2.redhat.com"]
  ComputeCount: 2
  ControllerCount: 3
  CephStorageCount: 2
  OvercloudControlFlavor: controller-d75f3dec-c770-5f88-9d4c-3fea1bf9c484
  OvercloudComputeFlavor: compute-b634c10a-570f-59ba-bdbf-0c313d745a10
  OvercloudCephStorageFlavor: ceph-cf1f074b-dadb-5eb8-9eb0-55828273fab7
parameter_defaults:
  NeutronNetworkType: 'vxlan'
  NeutronTunnelTypes: 'vxlan'


[stack@undercloud-0 ~]$ openstack image list
+--------------------------------------+--------+--------+
| ID                                   | Name   | Status |
+--------------------------------------+--------+--------+
| a68baaa1-559a-4815-8cf7-ea862b423492 | cirros | active |
+--------------------------------------+--------+--------+
[stack@undercloud-0 ~]$ neutron net-list
+--------------------------------------+----------------------------------------------------+-------------------------------------------------------+
| id                                   | name                                               | subnets                                               |
+--------------------------------------+----------------------------------------------------+-------------------------------------------------------+
| 3dc9c83a-f660-4f59-a2fb-bd8335a3766e | HA network tenant f2ec958dc7c64b74b37f74854f4e1d1e | c5627343-c0da-4b70-bc22-285d5b2df9b2 169.254.192.0/18 |
| 47d3f6a5-9b19-40da-ba57-ee8de6713d69 | public                                             | 882e06d5-5d18-43e5-b291-ddd203f6fd94 10.0.0.0/24      |
| 5c66b58e-40d6-4e03-97d2-ba37d7358d03 | tenantvxlan                                        | afcb9257-ed60-4f1c-8930-2ef068870690 192.168.32.0/24  |
| 6ccb44a2-0795-4a28-9c69-00c770e8c6e4 | stacknetwork                                       |                                                       |
+--------------------------------------+----------------------------------------------------+-------------------------------------------------------+

+----+------+--------+------------+-------------+----------+
[stack@undercloud-0 ~]$ nova hypervisor-list
+----+-----------------------+-------+---------+
| ID | Hypervisor hostname   | State | Status  |
+----+-----------------------+-------+---------+
| 3  | compute-1.localdomain | up    | enabled |
| 6  | compute-0.localdomain | up    | enabled |
+----+-----------------------+-------+---------+


------------------------+-----------------------------------------------+


Result:
[stack@undercloud-0 ~]$ nova boot --flavor 1 --image cirros --nic net-id=5c66b58e-40d6-4e03-97d2-ba37d7358d03 instance1
+--------------------------------------+-----------------------------------------------+
| Property                             | Value                                         |
+--------------------------------------+-----------------------------------------------+
| OS-DCF:diskConfig                    | MANUAL                                        |
| OS-EXT-AZ:availability_zone          |                                               |
| OS-EXT-SRV-ATTR:host                 | -                                             |
| OS-EXT-SRV-ATTR:hostname             | instance1                                     |
| OS-EXT-SRV-ATTR:hypervisor_hostname  | -                                             |
| OS-EXT-SRV-ATTR:instance_name        | instance-00000006                             |
| OS-EXT-SRV-ATTR:kernel_id            |                                               |
| OS-EXT-SRV-ATTR:launch_index         | 0                                             |
| OS-EXT-SRV-ATTR:ramdisk_id           |                                               |
| OS-EXT-SRV-ATTR:reservation_id       | r-ljwvb5w4                                    |
| OS-EXT-SRV-ATTR:root_device_name     | -                                             |
| OS-EXT-SRV-ATTR:user_data            | -                                             |
| OS-EXT-STS:power_state               | 0                                             |
| OS-EXT-STS:task_state                | scheduling                                    |
| OS-EXT-STS:vm_state                  | building                                      |
| OS-SRV-USG:launched_at               | -                                             |
| OS-SRV-USG:terminated_at             | -                                             |
| accessIPv4                           |                                               |
| accessIPv6                           |                                               |
| adminPass                            | JNHtbtRn388s                                  |
| config_drive                         |                                               |
| created                              | 2017-02-03T05:14:45Z                          |
| description                          | -                                             |
| flavor                               | m1.tiny (1)                                   |
| hostId                               |                                               |
| host_status                          |                                               |
| id                                   | 10e60100-2e10-47d7-b7f3-03b9d44cb1ab          |
| image                                | cirros (a68baaa1-559a-4815-8cf7-ea862b423492) |
| key_name                             | -                                             |
| locked                               | False                                         |
| metadata                             | {}                                            |
| name                                 | instance1                                     |
| os-extended-volumes:volumes_attached | []                                            |
| progress                             | 0                                             |
| security_groups                      | default                                       |
| status                               | BUILD                                         |
| tags                                 | []                                            |
| tenant_id                            | b50111007ebc452494817af76b932efa              |
| updated                              | 2017-02-03T05:14:45Z                          |
| user_id                              | e920b5c2e21a4009896628f67277ff34              |
+--------------


[stack@undercloud-0 ~]$ nova list
+----+------+--------+------------+-------------+----------+
| ID | Name | Status | Task State | Power State | Networks |
+----+------+--------+------------+-------------+----------+

[stack@undercloud-0 ~]$ . stackrc 
[stack@undercloud-0 ~]$ nova list
ssh heat-admin@+--------------------------------------+--------------+--------+------------+-------------+------------------------+
| ID                                   | Name         | Status | Task State | Power State | Networks               |
+--------------------------------------+--------------+--------+------------+-------------+------------------------+
| 9f23948f-3b90-4b6c-8750-255de801b20d | ceph-0       | ACTIVE | -          | Running     | ctlplane=192.168.24.6  |
| def930c8-36b6-4a15-b5b0-4ebf9618d2e3 | ceph-1       | ACTIVE | -          | Running     | ctlplane=192.168.24.10 |
| 8b06fd0f-0fca-4fbb-97c8-3f0b6f75135d | compute-0    | ACTIVE | -          | Running     | ctlplane=192.168.24.8  |
| 12e1f35e-b853-4aa1-9724-6facdad4b8b0 | compute-1    | ACTIVE | -          | Running     | ctlplane=192.168.24.13 |
| 01a20f51-1d30-472e-91ee-19c936a89b12 | controller-0 | ACTIVE | -          | Running     | ctlplane=192.168.24.20 |
| 0479a824-98de-48d0-8902-e39b6e6e511c | controller-1 | ACTIVE | -          | Running     | ctlplane=192.168.24.7  |
| 2ddc1d03-8595-4520-a405-83f117c83d41 | controller-2 | ACTIVE | -          | Running     | ctlplane=192.168.24.18 |
+--------------------------------------+--------------+--------+------------+-------------+------------------------+
[stack@undercloud-0 ~]$ ssh heat-admin@192.168.24.8 
The authenticity of host '192.168.24.8 (192.168.24.8)' can't be established.
ECDSA key fingerprint is da:d4:08:ab:51:7d:83:65:88:25:e1:04:6e:cf:8e:ac.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '192.168.24.8' (ECDSA) to the list of known hosts.
[heat-admin@compute-0 ~]$ sudo virsh list
 Id    Name                           State
----------------------------------------------------
 1     instance-00000006              running

[heat-admin@compute-0 ~]$ logout
Connection to 192.168.24.8 closed.
[stack@undercloud-0 ~]$ ssh heat-admin@192.168.24.13
The authenticity of host '192.168.24.13 (192.168.24.13)' can't be established.
ECDSA key fingerprint is b5:22:92:cb:12:ce:7f:ff:bd:db:67:68:4d:c0:18:c9.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added '192.168.24.13' (ECDSA) to the list of known hosts.
[heat-admin@compute-1 ~]$ sudo virsh list
 Id    Name                           State
----------------------------------------------------
 1     instance-00000003              running






Expected result:
The launched instance should appear in the table.

Comment 2 Dan Smith 2017-02-03 15:19:11 UTC
No cells are configured so you can't list anything:

2017-02-03 05:23:35.330 74737 ERROR nova.compute.api [req-86d85cf4-5013-4ee2-b844-3cdc003388a0 190ccf38660147cc9d388256276f3276 e40d956f38d144639c1a25d67ea36f6d - default default] No cells are configured, unable to list instances

Comment 3 Alexander Chuzhoy 2017-02-03 17:00:37 UTC
I didn't have to configure cells previously. Should that be done manually?

Comment 4 Stephen Gordon 2017-02-03 21:24:10 UTC
(In reply to Alexander Chuzhoy from comment #3)
> I didn't have to configure cells previously. Should that be done manually?

No but...

Comment 5 Stephen Gordon 2017-02-03 21:24:31 UTC

*** This bug has been marked as a duplicate of bug 1405098 ***


Note You need to log in before you can comment on or make changes to this bug.