Bug 140512 - [PATCH] please convert man pages from old encoding to UTF-8
Summary: [PATCH] please convert man pages from old encoding to UTF-8
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 139341
TreeView+ depends on / blocked
 
Reported: 2004-11-23 09:52 UTC by Jindrich Novy
Modified: 2013-07-02 23:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-25 22:35:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spec file patch to add the UTF-8 conversion (1016 bytes, patch)
2004-11-23 09:55 UTC, Jindrich Novy
no flags Details | Diff

Description Jindrich Novy 2004-11-23 09:52:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041020
Firefox/0.10.1

Description of problem:
Some of the man pages in the rpm package is in an old encoding and
need to be converted to UTF-8.

How reproducible:
Always

Steps to Reproduce:
1. LANG=pl_PL.UTF-8 man gendiff (the same for all Polish man pages)
2. LANG=sk_SK.UTF-8 man rpm


Actual Results:  man displays warning of old encoding

Expected Results:  display pages properly

Comment 1 Jindrich Novy 2004-11-23 09:55:12 UTC
Created attachment 107287 [details]
spec file patch to add the UTF-8 conversion

Comment 2 Miloslav Trmač 2004-11-23 13:19:10 UTC
/usr/share/man/sk/man8/rpm.8.gz needs converting from ISO-8859-2 too.

Comment 3 Jindrich Novy 2004-11-23 13:52:20 UTC
It's converted by the patch. Please look into it more carefully. (it's
the last file in the list)

Comment 4 Miloslav Trmač 2004-11-23 13:58:03 UTC
Oops, sorry, I didn't expect such a trick :)

Comment 5 Jeff Johnson 2004-11-23 14:33:58 UTC
The real problem is one of content, not encoding:

.\" translated into slovak by Peter Ivanyi <ivanyi@internet.sk>
.\" for rpm version 3.0.5-9.6x
.\"
.TH rpm 8 "22 December 1998" "Red Hat Software" "Red Hat Linux"

I use what PLD uses for encoding, since they actually maintain
their man pages, when I update man pages in rpm.



Comment 6 Jindrich Novy 2004-11-23 15:16:40 UTC
Hello Jeff,

it looks like this is not the only obsolete man page for rpm, see the
Russian man page (last updated 22th Apr. 1999). Should we drop them?
I think to have an old localized man page is better than nothing.

Almost all central european pages are pretty standardly encoded in
ISO-8859-2 but they should be encoded in UTF-8 in order to not to
solve encoding problems any more and to unify encoding. (It's about
four or more possible code pages for central Europe) Please see bug
139341. If you add the patch I think you could go on importing 3rd
party man pages assuming they're in ISO-8859-2 for central european
countries and we'll have them in UTF-8.


Comment 7 Jeff Johnson 2004-11-23 23:16:12 UTC
PLD concurs that utf8 is the way to go for eastern europe, will
have the conversion in rpm man pages in place next couple of days
in FC.


Comment 8 Jeff Johnson 2004-11-23 23:17:37 UTC
And I still quest content updates, if you know any native
speakers who are so inclined ;-)

Comment 9 Jindrich Novy 2004-11-24 08:19:03 UTC
You're lucky since both me and mitr are from central Europe (Czech
Rep.) so that we at least understand the man pages. Particularly for
the Slovak man page in comment 5 we have Peter Vrabec
(pvrabec@redhat.com) - native Slovak in our team so maybe it's a good
idea to contact him.

Comment 10 Jeff Johnson 2005-10-25 22:35:40 UTC
Fixed upstream afaik.


Note You need to log in before you can comment on or make changes to this bug.