Bug 140515 - Shift keypress from VNC client not received at server
Shift keypress from VNC client not received at server
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vino (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-23 06:10 EST by Andy Piper
Modified: 2013-03-05 22:42 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.10.0-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-20 13:05:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 155900 None None None Never

  None (edit)
Description Andy Piper 2004-11-23 06:10:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
I have been trying to use vino for remote access to my X session from
Windows. 

I can connect successfully, but the shift key does not seem to have
any effect when typing in a gnome-terminal on the remote desktop - so
no upper case characters or pipe (|) symbols can be typed, for
example. I have also tried using Caps Lock but that doesn't work
either. Needless to say this makes many UNIX operations a chore, or
impossible.

No special configuration, although I wasn't entirely sure what I
needed to do to enable remote access. I have the vnc packages
installed along with vino. VNC is set to run in runlevel 5. I have
enabled remote access with password authentication using the Remote
Access preference in GNOME.
This could be a vncserver problem, or an issue with the client, I'm
not sure.

I have run RealVNC 3.x and 4.x on the Windows side with the same
results. I've tried connecting from different Windows client machines.
I've also tried using various config options on the client side (send
keyboard events, etc).


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Configure remote access in GNOME
2. Connect using a Windows VNC client (RealVNC)
3. Attempt to type some characters in a terminal in uppercase using
the Shift key.
    

Actual Results:  Characters appear in lower case.

Additional info:
Comment 1 Alexander Kain 2005-02-01 18:44:08 EST
I have tried connecting with the TightVNC viewer, and I get similar results. The
shift key does work on most alpha keys (a, b, c, ), and even on the key with (,
<). However, on the (not keypad, but above alpha keys) numeric keys, shift has
no effect. Pressing the (2,@) key produces "2" no matter what the state of the
shift key is.
Comment 2 Alexander Kain 2005-02-02 13:43:40 EST
Additionally, I just figured out the following behavior:

press the key labeled (2,@). As before, SHIFT+that key does not produce "@"
(neither left nor right SHIFT key). However, when I press down the (2,@) key
long enough for the automatic repeat to come one, then, while continuing to hold
down the key, either left or right SHIFT produces the symbol "@", correctly.

Andy, see if it does this for you, too.

This is true for both TightVNC and RealVNC.

up2date Fedora Core 3, using the GNOME remote desktop. The clients are on
Windows XP.
Comment 3 Ian Clancy 2005-04-20 21:13:52 EDT
This bug is also reported at gnome http://bugzilla.gnome.org/ as bug 155900
Comment 4 Mark McLoughlin 2005-05-20 13:05:27 EDT
Should be fixed in rawhide:

* Fri May 20 2005 Mark McLoughlin <markmc@redhat.com> 2.10.0-4
- Fix various keyboarding handling issues:
   + bug #142974: caps lock not working
   + bug #140515: shift not working with some keys
   + bug #134451: over-eager key repeating

Note You need to log in before you can comment on or make changes to this bug.