Bug 134451 - vino server has keyboard bounce
vino server has keyboard bounce
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vino (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
: 142975 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-02 17:43 EDT by Thomas J. Baker
Modified: 2013-03-05 22:41 EST (History)
4 users (show)

See Also:
Fixed In Version: 2.10.0-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-20 13:04:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas J. Baker 2004-10-02 17:43:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040928
Firefox/0.10

Description of problem:
When connecting to my desktop via vnc and the vino server, I
experience a single keystroke being interpreted as multiple
keystrokes. It's happened with different vnc clients (solaris 9 and
FC3T2) to FC3T2 servers. Type a single space and out comes more than
one space on the other side. I don't believe this has always been
happening with vino, I've only noticed it since FC3T2. It's harder to
tell but I also think single mouse clicks are being multiplied too.

Version-Release number of selected component (if applicable):
vino-2.8.0-1

How reproducible:
Sometimes

Steps to Reproduce:
1. connect to a vino shared desktop via vnc
2. type
3.
    

Additional info:
Comment 1 Mark McLoughlin 2004-10-06 13:50:18 EDT
Okay, I think I've improved this a hell of a lot with:

* Thu Oct  7 2004 Mark McLoughlin <markmc@redhat.com> 2.8.0.1-1.1
- Don't hang with metacity's "reduced resources" mode (#134240)
- Improve the key repeat rate situation a good deal (#134451)


But, I don't think the problem is completely fixable - basically,
because of network lag and processing time on the server, if you have
your repeat rate set with a low enough delay, we'll trigger it.

So, I think the behaviour is fairly acceptable now, especially if you
increase your repeat rate delay slightly.
Comment 2 Thomas J. Baker 2004-10-08 13:33:05 EDT
I've got the new version installed but it doesn't seem any better. I'm
typing this in a vino viewed foxfire window and there isn't any
problem with normal typing. The place I see it most is reading email
with evolution. For instance, I'm currently sitting at a SunRay xterm
thing and vncing to my Dell 650N dual 3GHz 1GB system running FC3T2.
The network is 100MB switched. I'm reading fedora-test mailing list
and when I hit delete and evo has to scroll, it sometimes ends up
deleting 20 email messages. And it's more of an event bounce where I
see it happen with mouse clicks too. Do you think the case I've
described is in the "not completely fixable" class?

Now I've typed this entire message and not had a single problem. I
just tried the keyboard preference for repeat delay and I turned it up
some. In testing the rate in the test area, I didn't encounter any
problems either. I turned it up to half way and I still have the same
problems with evolution. What settings have you tried successfully?
Comment 3 Thomas J. Baker 2004-10-11 12:07:26 EDT
Just an update, a co-worker had the same problems with the KDE desktop
sharing from these Sun Ray terminals. Whenever there is scrolling on
the  server, it causes these multiple server side events for single
client side events (keystrokes and mouse clicks).
Comment 4 Mark McLoughlin 2004-11-19 09:07:08 EST
I never got back to looking at this again, but i was just discussing
the problem with someone else on irc so I thought I'd dump my thoughts
here:

  1) The problem here sounds like when a key press causes a large
     change in the display, Vino is so busy processing all the
     damage events from the Xserver there is a delay before it
     sees the key release event in the key and passes it on to the
     Xserver

  2) One way of fixing the problem is to ensure we always process
     incoming key events as soon as possible. I thought we already
     did a pretty good job of that, but there's probably only so
     you much you can do.

  3) Another way is to turn off keyboard repeat for key events which
     Vino injects. I don't think there's any proper way of doing that
     but what we could do is inject a fake key release with every
     key press we get and ignore key releases from the client. It
     gets a bit tricky when you consider modifiers, though.

Comment 5 Mark McLoughlin 2004-12-17 08:13:21 EST
*** Bug 142975 has been marked as a duplicate of this bug. ***
Comment 6 Aaron Gaudio 2004-12-17 09:58:37 EST
I'm having this same problem (I wrote up 142975 not realizing this one
was open). I've used VNC for a long time, but most often with
vncserver, not vino. I've been in situations where the network was
pretty slow, and yet I've never had this "keyboard bounce" problem
with vncserver, so there may be something more than just network lag
at work here. Hope that helps!
Comment 7 Mark McLoughlin 2005-05-20 13:04:57 EDT
Should be fixed in rawhide:

* Fri May 20 2005 Mark McLoughlin <markmc@redhat.com> 2.10.0-4
- Fix various keyboarding handling issues:
   + bug #142974: caps lock not working
   + bug #140515: shift not working with some keys
   + bug #134451: over-eager key repeating
Comment 8 Alexandre Oliva 2005-09-02 02:54:54 EDT
For the record, the patch for this bug introduced bug 158713.

Note You need to log in before you can comment on or make changes to this bug.