Bug 140527 - Pyton Error in Dual Head configuration
Pyton Error in Dual Head configuration
Status: CLOSED DUPLICATE of bug 136916
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-23 08:57 EST by Roland Kaeser
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Roland Kaeser 2004-11-23 08:57:37 EST
Description of problem:
The graphical screen configuration reports an pyton error when its
tried to configure a Matrox G550 for dual head. On the console it
reports: 
---
Traceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 208,
in ok
    primaryPCIBus = "PCI:%d:%d:%d" % (self.state.get_videocard_PCIBus(),
TypeError: int argument required
---
When after configuration the file should been saved.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Use a Matrox G550 Card on a x86 Computer
2. Install Fedora
3. Plug a second Monitor
4. Try to configure the card for the second monitor using the
system-config-display tool from the bash call. 
5. Look at the output of the program
  
Actual results:
aceback (most recent call last):
  File "/usr/share/system-config-display/xConfigDialog.py", line 208,
in ok
    primaryPCIBus = "PCI:%d:%d:%d" % (self.state.get_videocard_PCIBus(),
TypeError: int argument required


Expected results:
Saving the configuration and exit


Additional info:
Can be relational to an other bug which wrongly configures the matrox
cards regarding to the device section and pci address for the second
screen
Comment 1 Paul Nasrat 2004-11-23 09:00:18 EST
Testing update in updates-testing, final release coming



*** This bug has been marked as a duplicate of 136916 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:07:14 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.