This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 140590 - snd_intel8x0 / 82801BA/BAM AC'97 Audio -- no sound playing
snd_intel8x0 / 82801BA/BAM AC'97 Audio -- no sound playing
Status: CLOSED DUPLICATE of bug 144742
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-23 14:17 EST by James Martin
Modified: 2015-01-04 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-02 08:19:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Martin 2004-11-23 14:17:32 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
On a fresh install of FC3, my integrated soundcard with the
"82801BA/BAM AC'97 Audio" chipset and snd_intel8x0 module no longer
produces any sound--it worked fine under FC2.  I have run aumix,
alsamixer, kmix, and all the sound levels are set appropriately.  When
running XMMS and playing a sound file, you will see the sound waves,
but no audio is produced.  The speakers are on and work fine on
another machine.  system-config-soundcard detects the sound card, but
the test sound does not play either.  The closest problem I could find
was in this thread:

http://www.redhat.com/archives/fedora-test-list/2004-November/msg00734.html

I tried what this suggested, it didn't work.  I then tried doing what
it said but using "snd-intel8x0" module to exclude, but to no avail.

Version-Release number of selected component (if applicable):
kernel-2.6.9-1.678_FC3

How reproducible:
Always

Steps to Reproduce:
1.Install FC3 on a machine with 82801BA/BAM AC'97 Audio audio chipset.
2.Attempt to play a sound/music

    

Actual Results:  You will see sound levels are fine, that XMMS
actually working, but no sound is emitted from the computer.

Expected Results:  I expected music to play in XMMS just like it does
in FC2.

Additional info:

Here is the output of a couple commands:

lspci 

_____________

00:00.0 Host bridge: Intel Corp. 82815 815 Chipset Host Bridge and
Memory Controller Hub (rev 04)
00:02.0 VGA compatible controller: Intel Corp. 82815 CGC [Chipset
Graphics Controller] (rev 04)
00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev 11)
00:1f.0 ISA bridge: Intel Corp. 82801BA ISA Bridge (LPC) (rev 11)
00:1f.1 IDE interface: Intel Corp. 82801BA IDE U100 (rev 11)
00:1f.2 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #1) (rev 11)
00:1f.3 SMBus: Intel Corp. 82801BA/BAM SMBus (rev 11)
00:1f.4 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #2) (rev 11)
00:1f.5 Multimedia audio controller: Intel Corp. 82801BA/BAM AC'97
Audio (rev 11)
01:07.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100]
(rev 0d)
01:09.0 SCSI storage controller: LSI Logic / Symbios Logic 53c875 (rev 03)


lsmod
____________

Module                  Size  Used by
i810                   79685  2
parport_pc             24705  1
lp                     11565  0
parport                41737  2 parport_pc,lp
autofs4                24005  0
i2c_dev                10433  0
i2c_core               22081  1 i2c_dev
nfs                   221765  1
lockd                  63337  2 nfs
sunrpc                160421  4 nfs,lockd
dm_mod                 54741  0
button                  6481  0
battery                 8517  0
ac                      4805  0
md5                     4033  1
ipv6                  232705  10
uhci_hcd               31449  0
snd_intel8x0           34829  2
snd_ac97_codec         64401  1 snd_intel8x0
snd_pcm_oss            47608  0
snd_mixer_oss          17217  2 snd_pcm_oss
snd_pcm                97993  2 snd_intel8x0,snd_pcm_oss
snd_timer              29765  1 snd_pcm
snd_page_alloc          9673  2 snd_intel8x0,snd_pcm
gameport                4801  1 snd_intel8x0
snd_mpu401_uart         8769  1 snd_intel8x0
snd_rawmidi            26725  1 snd_mpu401_uart
snd_seq_device          8137  1 snd_rawmidi
snd                    54053  11
snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore               9889  2 snd
e100                   39493  0
mii                     4673  1 e100
floppy                 58609  0
ext3                  116809  2
jbd                    74969  1 ext3
sym53c8xx              70113  0
scsi_transport_spi     12353  1 sym53c8xx
sd_mod                 16961  0
scsi_mod              118417  3 sym53c8xx,scsi_transport_spi,sd_mod
Comment 1 Sitsofe Wheeler 2004-12-03 05:01:27 EST
This sounds a lot like bug 135979 ...

Does doing the following help:
1. Adding snd-intel8x0m to /etc/hotplug/blacklist
2. Edit /etc/asound.conf abd set the period_size to 512
3. Rebooting

If to does then this is surely a duplicate...
Comment 2 James Martin 2004-12-09 12:48:45 EST
I gave your solution a shot, still doesn't work.  Thanks anyhow.
Comment 3 Philip Edelbrock 2005-01-04 13:45:51 EST
I had a lot of problems with FC3 and 82801EB/ER (ICH5/ICH5R) AC'97. 
My solution was to shut down asound, copy my old /etc/asound.state
from the old FC2 system, put it on the new FC3 install, and then start
asound again.  Then, everything worked fine.  Something seemed to be
nutty with the way the initial state gets set up.  Mucking with mixers
and iecset never got me anywhere.
Comment 4 Luc Blecha 2005-02-10 08:38:01 EST
I have the same problem as Philip had! Is it possible to have the
/etc/asound.state to give a try?
Comment 5 Warren Togami 2005-02-10 19:44:50 EST
More likely a duplicate of Bug #144742?  Please test the workaround there.
Comment 6 Dave Jones 2005-07-15 13:55:35 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 7 Marius Andreiana 2005-08-02 08:19:04 EDT
No reply to Warren's comment, marking as dupe as I agree

*** This bug has been marked as a duplicate of 144742 ***

Note You need to log in before you can comment on or make changes to this bug.