Bug 1406102 - [RFE][spine-leaf] Allow defining composable networks in director
Summary: [RFE][spine-leaf] Allow defining composable networks in director
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Upstream M3
: 12.0 (Pike)
Assignee: Dan Sneddon
QA Contact: Alexander Chuzhoy
URL: https://blueprints.launchpad.net/trip...
Whiteboard: upstream_milestone_pike-3 upstream_de...
: 1361714 1381704 (view as bug list)
Depends On: 1547088
Blocks: 1281573 1389435 1442136 1214284 1241596 1396159 1459148 1497893 1615663
TreeView+ depends on / blocked
 
Reported: 2016-12-19 17:56 UTC by Ramon Acedo
Modified: 2019-12-16 07:28 UTC (History)
25 users (show)

Fixed In Version: openstack-tripleo-heat-templates-7.0.3-0.20171023134947.8da5e1f.el7ost
Doc Type: Enhancement
Doc Text:
Director now supports the creation of custom networks during the deployment and update phases. These additional networks can be used for dedicated network controllers, Ironic baremetal nodes, system management, or to create separate networks for different roles. A single data file ('network_data.yaml') manages the list of networks that will be deployed. The role definition process then assigns the networks to the required roles.
Clone Of:
Environment:
Last Closed: 2017-12-13 20:57:54 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 409920 'None' MERGED Make network-isolation environment rendered for all roles 2020-04-30 11:21:32 UTC
OpenStack gerrit 409921 'None' MERGED Add network_data.yaml to encapsulate list of networks for j2 2020-04-30 11:21:32 UTC
OpenStack gerrit 469416 'None' MERGED Pass all role data into role templates when rendering 2020-04-30 11:21:32 UTC
OpenStack gerrit 469822 'None' MERGED Pass network_data into per-role j2 templating 2020-04-30 11:21:32 UTC
OpenStack gerrit 469853 'None' MERGED Convert role templates to consume roles_data map 2020-04-30 11:21:33 UTC
OpenStack gerrit 469854 'None' MERGED Modify generic role template to support custom networks 2020-04-30 11:21:33 UTC
OpenStack gerrit 475612 'None' MERGED Render isolated network templates using jinja2 2020-04-30 11:21:33 UTC
OpenStack gerrit 480272 'None' MERGED Convert controller-role.yaml to role.role.j2.yaml 2020-04-30 11:21:33 UTC
OpenStack gerrit 482623 'None' MERGED Convert compute-role.yaml to role.role.j2.yaml 2020-04-30 11:21:33 UTC
OpenStack gerrit 482624 'None' MERGED Convert objectstorage-role.yaml to role.role.j2.yaml 2020-04-30 11:21:33 UTC
OpenStack gerrit 482625 'None' MERGED Convert blockstorage-role.yaml to role.role.j2.yaml 2020-04-30 11:21:34 UTC
OpenStack gerrit 482626 'None' MERGED Convert cephstorage-role.yaml to role.role.j2.yaml 2020-04-30 11:21:34 UTC
OpenStack gerrit 500146 'None' MERGED Remove ipv6 specific network templates 2020-04-30 11:21:34 UTC
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Internal Links: 1503838 1547088

Description Ramon Acedo 2016-12-19 17:56:01 UTC
Currently, we can only use the networks that are defined in the TripleO templates (i.e. control plane, external, internal API, tenant, storage, storage management and generic management).

A user might require additional networks or might want to label a network to reflect its role. To achieve this, director should allow the user to compose networks for using in the Overcloud.

Comment 1 Ramon Acedo 2017-01-03 11:08:51 UTC
Some related upstream work: https://review.openstack.org/#/c/409921/

Comment 7 Ramon Acedo 2017-05-24 10:19:43 UTC
Steve, are there any other patches required to complete the composable networks work after OpenStack Gerrit patch 409921 was merged?

Comment 12 Bob Fournier 2017-07-21 14:03:22 UTC
*** Bug 1381704 has been marked as a duplicate of this bug. ***

Comment 15 Alexander Chuzhoy 2017-11-14 16:08:12 UTC
Verified:

Environment:
openstack-tripleo-heat-templates-7.0.3-0.20171024200825.el7ost.noarch

Successfully deployed OC with:
composable networks for all roles.
IPv6 composable networks.
predictable IP on ipv4 and ipv6 networks.

Comment 19 errata-xmlrpc 2017-12-13 20:57:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462

Comment 20 Bob Fournier 2018-01-08 15:09:57 UTC
*** Bug 1361714 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.