Bug 1241596 - [RFE] Need to be able to deploy and manage multiple Overclouds from a single Undercloud
Summary: [RFE] Need to be able to deploy and manage multiple Overclouds from a single ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 15.0 (Stein)
Hardware: All
OS: Linux
medium
high
Target Milestone: Upstream M2
: 15.0 (Stein)
Assignee: Emilien Macchi
QA Contact: Sasha Smolyak
URL: https://blueprints.launchpad.net/trip...
Whiteboard: upstream_milestone_none upstream_defi...
: 1275654 (view as bug list)
Depends On: 1214284 1406102 1671766
Blocks: 1188000 1337935 1476902 1705124
TreeView+ depends on / blocked
 
Reported: 2015-07-09 15:09 UTC by Gordon Keegan
Modified: 2021-06-10 10:56 UTC (History)
38 users (show)

Fixed In Version: openstack-tripleo-heat-templates-10.5.1-0.20190701110422.889d4d4.el8ost
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:15:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1632327 0 None None None 2016-11-21 10:20:46 UTC
Red Hat Product Errata RHEA-2019:2811 0 None None None 2019-09-21 11:16:34 UTC

Description Gordon Keegan 2015-07-09 15:09:23 UTC
Description of problem:
Customer needs to be able to deploy and manage multiple Overclouds from a single Undercloud environment.  They have a need to segregate out multiple Overclouds in a single location and not create a separate Undercloud and provisioning network for each one.

Comment 4 Mike Burns 2015-10-27 23:16:17 UTC
*** Bug 1275654 has been marked as a duplicate of this bug. ***

Comment 7 Mike Burns 2016-04-07 20:43:53 UTC
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.

Comment 9 RHEL Program Management 2016-08-02 11:37:19 UTC
Quality Engineering Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Comment 10 Jaromir Coufal 2016-10-18 14:36:13 UTC
Very complex request, mainly for networking part. Removing target for now due to short Ocata release.

Comment 16 Red Hat Bugzilla Rules Engine 2017-01-20 18:09:28 UTC
This bugzilla has been removed from the release and needs to be reviewed for targeting another release.

Comment 18 Red Hat Bugzilla Rules Engine 2017-02-06 15:47:36 UTC
This bugzilla has been removed from the release and needs to be reviewed and Triaged for another Target Release.

Comment 21 Jaromir Coufal 2017-08-10 19:18:08 UTC
Moving out of OSP13. Delivering containerized undercloud is having higher priority.

Comment 23 Jaromir Coufal 2018-05-11 12:59:05 UTC
Due to ongoing updates of the underlying technology to containers which for undercloud is targeted for RHOSP 14 [0] any new features to undercloud node will be pushed after this update. Therefor we will re-evaluate this feature for RHOSP 15 target.

[0] https://bugzilla.redhat.com/show_bug.cgi?id=1419744

Comment 26 James Slagle 2018-08-29 21:09:15 UTC
We'll need more requirements around how to make this work.

Should the overclouds be separated by different tenants in the undercloud? Right now, the admin tenant is used for everything.

What if anything would be shared between  multiple overclouds? The provisioning network may need to be shared. What about other networks?

Comment 27 Jaromir Coufal 2018-09-05 19:49:04 UTC
Initial request is to deploy multiple standalone stacks. Let's keep it as simple as possible and make sure there is a good UX around it.

Single tenant is acceptable for the first iteration of this feature.

First step should be independent deployments (if there is need for shared provisioning network, that is OK). Further requirements on connecting multiple overclouds and share some resources (networks, replication of data, etc) will come in next iterations with helping requirements from multi-site epic leads.

Comment 42 Sasha Smolyak 2019-09-18 12:38:10 UTC
The automation is ready, the feature is verified

Comment 44 errata-xmlrpc 2019-09-21 11:15:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.