Bug 140667 - suspend to APM doesn't work because of root permissions
suspend to APM doesn't work because of root permissions
Status: CLOSED DUPLICATE of bug 121061
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-23 22:15 EST by Andrew D. Stadler
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew D. Stadler 2004-11-23 22:15:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Other bugs have pointed out that the battery applet's default suspend
command is /usr/bin/apm -s which doesn't work for ACPI systems.

I would also like to point out that it doesn't work for APM systems
either.

Bug #1:  silent failure.  Should at least give some diagnostic results
to the user so you know that something went wrong.

Bug #2:  Testing "/usr/bin/amp -s" in a shell demonstrates the
problem, as it returns "apm: Operation not permitted".  Some other
command is required, OR, perhaps apm has its permissions set too
restrictively.

(it's possible to make it work by typing "sudo /usr/bin/amp -s")

Besides suggesting that these elements should be repaired for a better
"out of box" experience, can you suggest a specific workaround or fix?

Version-Release number of selected component (if applicable):
gnome-applets-2.8.0-5

How reproducible:
Always

Steps to Reproduce:
1.  Boot system with APM
2.  Try the suspend feature in the battery applet.  Doesn't work.
3.  Try the suspend command in a shell.  Doesn't work.
    

Additional info:
Comment 1 Mark McLoughlin 2005-01-05 06:03:43 EST

*** This bug has been marked as a duplicate of 121061 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:07:15 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.