Bug 1406785 - Dependency issues with Rancid on RHEL/CentOS 7.3
Summary: Dependency issues with Rancid on RHEL/CentOS 7.3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: rancid
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: David Brown
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-12-21 13:29 UTC by Jon Archer
Modified: 2019-03-21 22:49 UTC (History)
8 users (show)

Fixed In Version: rancid-3.9-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-12 17:55:16 UTC


Attachments (Terms of Use)

Description Jon Archer 2016-12-21 13:29:08 UTC
Description of problem:
Looks like a dependency issue with rancid/perl (perl version included RHEL/CentOS 7.3)

Version-Release number of selected component (if applicable):
rancid 3.2-2
perl 5.16.3-291

How reproducible:
Everytime

Steps to Reproduce:
1. yum install rancid on fresh 7.3 install
2.
--> Processing Dependency: perl(newgetopt.pl) for package: rancid-3.2-2.el7.x86_64
--> Finished Dependency Resolution
Error: Package: rancid-3.2-2.el7.x86_64 (EPEL)
           Requires: perl(newgetopt.pl)


Actual results:
Dependency failure

Expected results:
Package installation successful

Additional info:

Comment 2 Fedora Update System 2017-08-17 15:25:25 UTC
rancid-3.2-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-c4362e074a

Comment 3 Fedora Update System 2017-08-18 20:23:12 UTC
rancid-3.2-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-c4362e074a

Comment 4 Stefan Neufeind 2017-09-15 22:45:04 UTC
Seems the dependency is still a problem here:

rror: Package: rancid-3.2-3.el7.x86_64 (epel-testing)
           Requires: perl(newgetopt.pl)

Comment 5 Stefan Neufeind 2017-09-18 11:29:17 UTC
afaik perl(newgetopt.pl) should be offered by perl-Perl4-CoreLibs. Manualy installing that dep before didn't resolve the issue. Ignoring that one missing dep when installing rancid worked however and rancid seems to work. Is it just a naming-issue maybe? How could the package have been built when the dep does not exist/validate?

Comment 6 Sebastian Ahndorf 2017-09-18 14:30:16 UTC
newgetopt.pl is provides bei perl-Getopt-Long, but unfortunately the rpm does not include a related "Provides:" statement in the spec File.
See https://bugzilla.redhat.com/show_bug.cgi?id=1481811#c9

Comment 7 Stefan Neufeind 2017-09-18 14:39:20 UTC
Or if easier: Can we maybe have the rancid-package simply depend on perl-Getopt-Long?

Comment 8 Sebastian Ahndorf 2017-09-18 14:46:39 UTC
I don't think this will fix the issue, because the dependency to perl(newgetopt.pl) comes from some perl file shipped with rancid and not from the rancid RPM .spec file.

I have filed https://bugzilla.redhat.com/show_bug.cgi?id=1492742 to fix this in perl-Getopt-Long RPM.

Comment 9 Charles R. Anderson 2019-02-12 17:55:16 UTC

*** This bug has been marked as a duplicate of bug 1481811 ***

Comment 10 Fedora Update System 2019-02-12 17:59:18 UTC
rancid-3.9-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-6bcc0011aa

Comment 11 Fedora Update System 2019-02-13 06:24:20 UTC
rancid-3.9-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-6bcc0011aa

Comment 12 Fedora Update System 2019-03-21 22:49:46 UTC
rancid-3.9-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.