Bug 1481811 - rancid is not installable after RHEL-7.4 update
Summary: rancid is not installable after RHEL-7.4 update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: rancid
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Brown
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1485239 (view as bug list)
Depends On: 1492742
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-08-15 19:12 UTC by Tuomo Soini
Modified: 2019-03-21 22:49 UTC (History)
16 users (show)

Fixed In Version: rancid-3.9-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-12 18:01:32 UTC


Attachments (Terms of Use)

Description Tuomo Soini 2017-08-15 19:12:31 UTC
RHEL-7.4 moved perl-Perl4-Corelibs to separate pacakge, version 0.003-7.el7 which doesn't any more include perl(newgetopt.pl) so rancid can't be installed any more.

Comment 1 Fedora Update System 2017-08-17 15:25:32 UTC
rancid-3.2-3.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-c4362e074a

Comment 2 Tuomo Soini 2017-08-17 18:37:28 UTC
That build doesn't help. perl(newgetopt.pl) requirement won't go away without patching software.

Comment 3 David Brown 2017-08-17 22:25:18 UTC
Yeah, even updating to the latest version doesn't solve the issue... We'll have to wait for the developers to come up with a patch.

Comment 4 Fedora Update System 2017-08-18 20:23:17 UTC
rancid-3.2-3.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-c4362e074a

Comment 5 Sven Lankes 2017-08-25 09:55:38 UTC
*** Bug 1485239 has been marked as a duplicate of this bug. ***

Comment 6 Tuomo Soini 2017-08-25 10:31:30 UTC
There still is no perl module 'perl(newgetopt.pl) - should that be carried by this package when there is no other users?

Comment 7 Ruben Püttmann 2017-09-11 07:17:06 UTC
Is it not an option to move newgetopt.pl in an seperate package?
Also we could bring rancid to an current version (3.6.2) ....

Comment 8 Ruben Püttmann 2017-09-15 09:13:24 UTC
Centos 7.4 is now out and rancid is not use able anymore. 
Any progress

Comment 9 Sebastian Ahndorf 2017-09-18 14:20:46 UTC
I have digged into this problem and to me the problem is as follows:

perl-Perl4-Corelibs of RHEL 7.4 / CentOS 7.4 does not provide "perl(newgetopt.pl)" anymore. In the .spec File of the SRPM you can see it has been removed, because it is provided by perl-Getopt-Long anyway:
"# newgetopt.pl is distributed by Getopt-Long, CPAN RT#102212" Line58

Unfortunately perl-Getopt-Long is missing a "Provides: perl(newgetopt.pl)" in its spec-File. So the problem should be fixed at perl-Getopt-Long rpm.

I am not sure who is the current maintainer of perl-Getopt-Long rpm. Maybe this can be done by dmach@redhat.com ? Or maybe jplesnik@redhat.com (maintainer of perl-Perl4-Corelibs rpm) ?

Comment 10 Sebastian Ahndorf 2017-09-18 14:44:02 UTC
I have filed https://bugzilla.redhat.com/show_bug.cgi?id=1492742 to fix this.

Comment 11 Tuomo Soini 2017-09-18 14:55:42 UTC
Ok. There is simpler work-around for this issue as it's extreamly difficult to get redhat fixing their bugs in same release.

Filtering out perl(newgetopt.pl) requirement from package.

Require: perl-Getopt-Long

That will fix the issue in this package.

Comment 12 Dave 2017-09-27 16:27:42 UTC
Agreed!

(In reply to Tuomo Soini from comment #11)
> Ok. There is simpler work-around for this issue as it's extreamly difficult
> to get redhat fixing their bugs in same release.
> 
> Filtering out perl(newgetopt.pl) requirement from package.
> 
> Require: perl-Getopt-Long
> 
> That will fix the issue in this package.

Comment 13 andrewm659 2017-11-09 22:03:56 UTC
IS this going to updated/fixed soon?

Comment 14 Anita 2017-11-15 19:03:44 UTC
Workaround:
1.yum install rpmrebuild

2.rpmrebuild -e perl-Getopt-Long-2.40-2.el7.noarch

2.1scroll down in to the file to Providers and add line 
Provides: perl(newgetopt.pl)

3. cd to the directory of your new rpm 
4. yum remove perl-Getopt-Long-2.40-2.el7.noarch
5.yum install newly created rpm package
6. yum install rancid 
:)

Comment 15 Dave 2017-11-15 21:15:14 UTC
Haha excellent, I forgot you could even do that!! 

Thanks!

(In reply to Anita from comment #14)
> Workaround:
> 1.yum install rpmrebuild
> 
> 2.rpmrebuild -e perl-Getopt-Long-2.40-2.el7.noarch
> 
> 2.1scroll down in to the file to Providers and add line 
> Provides: perl(newgetopt.pl)
> 
> 3. cd to the directory of your new rpm 
> 4. yum remove perl-Getopt-Long-2.40-2.el7.noarch
> 5.yum install newly created rpm package
> 6. yum install rancid 
> :)

Comment 16 andrewm659 2017-12-08 20:56:44 UTC
Should this uninstall lots of perl packages?  Will this break anything?


 perl-Mozilla-LDAP                        x86_64                  1.5.3-12.el7                              @base                      444 k
 perl-Net-Daemon                          noarch                  0.48-5.el7                                @base                      116 k
 perl-NetAddr-IP                          x86_64                  4.069-3.el7                               @base                      320 k
 perl-Package-Constants                   noarch                  1:0.02-292.el7                            @base                      4.6 k
 perl-PathTools                           x86_64                  3.40-5.el7                                @anaconda                  170 k
 perl-PlRPC                               noarch                  0.2020-14.el7                             @base                       69 k
 perl-Pod-Escapes                         noarch                  1:1.04-292.el7                            @anaconda                   21 k
 perl-Pod-Perldoc                         noarch                  3.20-4.el7                                @anaconda                  163 k
 perl-Pod-Simple                          noarch                  1:3.28-4.el7                              @anaconda                  526 k
 perl-Pod-Usage                           noarch                  1.63-3.el7                                @anaconda                   44 k
 perl-Scalar-List-Utils                   x86_64                  1.27-248.el7                              @anaconda                   66 k
 perl-Socket                              x86_64                  2.010-4.el7                               @anaconda                  112 k
 perl-Storable                            x86_64                  2.45-3.el7                                @anaconda                  177 k
 perl-TermReadKey                         x86_64                  2.30-20.el7                               @anaconda                   59 k
 perl-Test-Harness                        noarch                  3.28-3.el7                                @anaconda                  593 k
 perl-Text-ParseWords                     noarch                  3.29-4.el7                                @anaconda                   16 k
 perl-Thread-Queue                        noarch                  3.02-2.el7                                @anaconda                   27 k
 perl-Time-HiRes                          x86_64                  4:1.9725-3.el7                            @anaconda                   92 k
 perl-Time-Local                          noarch                  1.2300-2.el7                              @anaconda                   43 k
 perl-XML-Parser                          x86_64                  2.41-10.el7                               @anaconda                  628 k
 perl-constant                            noarch                  1.27-2.el7                                @anaconda                   26 k
 perl-libs                                x86_64                  4:5.16.3-292.el7                          @anaconda                  1.6 M
 perl-macros                              x86_64                  4:5.16.3-292.el7                          @anaconda                  5.0 k
 perl-parent                              noarch                  1:0.225-244.el7                           @anaconda                  8.0 k
 perl-podlators                           noarch                  2.5.1-3.el7                               @anaconda                  281 k
 perl-threads                             x86_64                  1.87-4.el7                                @anaconda                   96 k
 perl-threads-shared                      x86_64                  1.43-6.el7                                @anaconda                   72 k
 redhat-rpm-config                        noarch                  9.1.0-76.el7.centos                       @anaconda                  167 k
 rpm-build                                x86_64                  4.11.3-25.el7                             @anaconda                  320 k
 rpmrebuild                               noarch                  2.11-3.el7                                @epel                      181 k
 slapi-nis                                x86_64                  0.56.0-4.el7                              @base                      422 k
 subversion                               x86_64                  1.7.14-11.el7_4                           @updates                   4.6 M
 systemtap                                x86_64                  3.1-3.el7                                 @anaconda                  197 k
 systemtap-client                         x86_64                  3.1-3.el7                                 @anaconda                  9.6 M
 systemtap-devel                          x86_64                  3.1-3.el7                                 @anaconda                  7.2 M
 vim-enhanced                             x86_64                  2:7.4.160-2.el7                           @anaconda                  2.2 M

Transaction Summary
=============================================================================================================================================
Remove  1 Package (+71 Dependent packages)

Installed size: 178 M
Is this ok [y/N]:

Comment 17 Roman Brunka 2018-02-12 09:02:52 UTC
Thanks @Anita,

@andrewm659@outlook.com, modified workaround in your case:

1.yum install rpmrebuild
2.rpmrebuild -e perl-Getopt-Long-2.40-2.el7.noarch
2.1 scroll down in to the file to Providers and add line 
Provides: perl(newgetopt.pl)
3. cd to the directory of your new rpm
4. rpm --replacepkgs -ihv perl-Getopt-Long-2.40-2.el7.noarch.rpm
5. yum install rancid

Regards :)

Comment 18 andrewm659 2018-02-19 21:34:33 UTC
That worked.  Thank you.

Comment 19 Charles R. Anderson 2019-02-12 17:53:51 UTC
FYI, this appears to be no longer an issue in at least CentOS 7.6:

>cat /etc/redhat-release 
CentOS Linux release 7.6.1810 (Core)

> rpm -q --whatprovides 'perl(newgetopt.pl)'
perl-Getopt-Long-2.40-3.el7.noarch

Comment 20 Charles R. Anderson 2019-02-12 17:55:16 UTC
*** Bug 1406785 has been marked as a duplicate of this bug. ***

Comment 21 Fedora Update System 2019-02-12 17:59:19 UTC
rancid-3.9-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-6bcc0011aa

Comment 22 Fedora Update System 2019-02-13 06:24:21 UTC
rancid-3.9-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2019-6bcc0011aa

Comment 23 Fedora Update System 2019-03-21 22:49:48 UTC
rancid-3.9-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.