Bug 140735 - Ghostscript renders keywords and strings poorly
Ghostscript renders keywords and strings poorly
Status: CLOSED DUPLICATE of bug 140584
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-24 11:00 EST by Randy B
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-24 11:21:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Example code (4.30 KB, text/plain)
2004-11-24 11:01 EST, Randy B
no flags Details
Example PDF output (108.35 KB, application/octet-stream)
2004-11-24 11:02 EST, Randy B
no flags Details
Script used to generate PDF from perl code (292 bytes, text/plain)
2004-11-24 11:03 EST, Randy B
no flags Details

  None (edit)
Description Randy B 2004-11-24 11:00:50 EST
I'm really not that familiar with the inner workings of ghostscript, 
so this may be more of a headsmack than a bug.

Recently, I migrated from RH-9.0 to FC3; I use my linux system to 
develop a lot of Perl for my company, and specifically use a2ps and 
ps2pdf to generate nice hardcopies of the source for reviews using 
the following script, called 'pl2pdf':

The above script used to put out nicely formatted, two page per sheet 
code, provided the code stayed within 80 columns (which I strictly 
hold to).  Now, I get lines that overrun from one page to another, 
especially in the raw postscript (ps2pdf seems to clean up some of 
it).  Fixed fonts, strings, and keywords all do this.

Version-Release number of selected component (if applicable): n/a


How reproducible: Every time


Steps to Reproduce: See attached shell script
  
Actual results: See PDF attachment

Expected results: Properly rendered code @ 80 columns

Additional info: See the attachment for a sanitized (corporate 
reasons) piece of code that [mostly] displays what I'm talking 
about.  I've used kghostview, ggv, xpdf, and Acrobat Reader (latest 
all) to render this, and come up with the same results in each.
Comment 1 Randy B 2004-11-24 11:01:36 EST
Created attachment 107397 [details]
Example code
Comment 2 Randy B 2004-11-24 11:02:31 EST
Created attachment 107398 [details]
Example PDF output
Comment 3 Randy B 2004-11-24 11:03:15 EST
Created attachment 107399 [details]
Script used to generate PDF from perl code
Comment 4 Tim Waugh 2004-11-24 11:21:59 EST
Sounds like bug #140584.

*** This bug has been marked as a duplicate of 140584 ***

Note You need to log in before you can comment on or make changes to this bug.