Bug 140930 - [PATCH] Missing AppleTalk ioctl for the 32bit/64bit mapping
[PATCH] Missing AppleTalk ioctl for the 32bit/64bit mapping
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Riek
Brian Brock
: FutureFeature
: 142890 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-26 11:03 EST by Helmut Tschemernjak
Modified: 2007-11-30 17:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:12:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Helmut Tschemernjak 2004-11-26 11:03:53 EST
Description of problem:
Missing AppleTalk ioctl for the 32bit/64bit mapping
The patch (at end) will fix the missing AppleTalk kernel ioctls for the 32 API into 
64Bit API translation.

We need the AppleTalk networking for our EtherShare product. It would be 
good if the "appletalk" module gets included by default instead of 
building the kernel manually with the appletalk option enabled.

It would be great if somebody can confirm that the patches are getting 
integrated.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
2) ---- /usr/src/linux-2.4/arch/x86_64/ia32/ia32_ioctl.c -----
--- ia32_ioctl.c.SAVE   2004-11-26 11:51:31.000000000 +0100
+++ ia32_ioctl.c        2004-11-26 11:59:25.000000000 +0100
@@ -61,6 +61,7 @@
  #include <linux/ctype.h>
  #include <net/bluetooth/bluetooth.h>
  #include <net/bluetooth/rfcomm.h>
+#include <linux/atalk.h>
  #if defined(CONFIG_BLK_DEV_LVM) || defined(CONFIG_BLK_DEV_LVM_MODULE)
  /* Ugh. This header really is not clean */
  #define min min
@@ -4251,6 +4252,13 @@
  HANDLE_IOCTL(SIOCSIFMAP, dev_ifsioc)
  HANDLE_IOCTL(SIOCGIFADDR, dev_ifsioc)
  HANDLE_IOCTL(SIOCSIFADDR, dev_ifsioc)
+
+/* ioctls used by appletalk ddp.c */
+HANDLE_IOCTL(SIOCATALKDIFADDR, dev_ifsioc)
+HANDLE_IOCTL(SIOCDIFADDR, dev_ifsioc)
+HANDLE_IOCTL(SIOCSARP, dev_ifsioc)
+HANDLE_IOCTL(SIOCDARP, dev_ifsioc)
+
  HANDLE_IOCTL(SIOCGIFBRDADDR, dev_ifsioc)
  HANDLE_IOCTL(SIOCSIFBRDADDR, dev_ifsioc)
  HANDLE_IOCTL(SIOCGIFDSTADDR, dev_ifsioc)
Comment 1 Ernie Petrides 2004-11-30 16:36:26 EST
This is a feature request.  Appletalk is currently unsupported.
Comment 2 Helmut Tschemernjak 2004-12-01 07:54:46 EST
We need the AppleTalk for six turnkey products running on RedHat ES/AS 3, we have 
about 1300 Linux based server installations. Please fix this bug and and include AppleTalk 
protocol as a module by default in the next version.

The same patch is already in the kernel 2.6.9+patches (done by me posted via Andy 
Kleen).
Comment 3 Suzanne Hillman 2004-12-14 17:07:38 EST
Internal RFE bug #142890 submitted; will be considered for future releases.
Comment 5 Ernie Petrides 2005-10-06 19:32:18 EDT
*** Bug 142890 has been marked as a duplicate of this bug. ***
Comment 6 David Lawrence 2006-03-09 20:23:58 EST
NEEDINFO_PM status has been obsoleted. Changing status to NEEDINFO and assigning
to riek@redhat.com
Comment 7 RHEL Product and Program Management 2007-10-19 15:12:58 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.