Bug 1409559 - find-as-you-type doesn't work in the External tracker select-list
Summary: find-as-you-type doesn't work in the External tracker select-list
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: User Interface
Version: 5.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: 5.0
Assignee: Jeff Fearn 🐞
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-02 13:22 UTC by Ales Zelinka
Modified: 2018-12-09 06:29 UTC (History)
3 users (show)

Fixed In Version: 5.0.3.rh23
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1418904 (view as bug list)
Environment:
Last Closed: 2017-02-06 01:24:28 UTC


Attachments (Terms of Use)

Description Ales Zelinka 2017-01-02 13:22:16 UTC
Description of problem:
There's quite a few External trackers available. It's convenient to select corretn one by starting typing its name. This doesn't work in beta of B5.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. visit a bug details page (show_bug.cgi)
2. try to add external tracker: open "Add External Bug: Tracker" list by clicking it
3. start typing "TCMS"

Actual results:
Nothing, typing a tracker name has no effect

Expected results:
"TCMS test case" external tracker gets selected

Comment 1 Jeff Fearn 🐞 2017-01-08 23:42:16 UTC
This is because of the stupid "-- Do Not Change --" entry which is a default selected option, it should not exist and there should be no default selected option.

Work around: If you backspace away the default option, search works as expected.

Comment 2 Rony Gong 🔥 2017-02-03 03:42:05 UTC
Seems you only do this change on bug detail page, how about also do this change on the bug entry page?

Comment 3 Jeff Fearn 🐞 2017-02-03 03:50:04 UTC
(In reply to Rony Gong from comment #2)
> Seems you only do this change on bug detail page, how about also do this
> change on the bug entry page?

Clone the bug plz

Comment 4 Rony Gong 🔥 2017-02-03 05:07:27 UTC
Tested on QA environment(5.0.3-rh23)
Result: Pass


Note You need to log in before you can comment on or make changes to this bug.