Bug 1418904 - find-as-you-type doesn't work in the External tracker select-list in the entry bug page
Summary: find-as-you-type doesn't work in the External tracker select-list in the entr...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: User Interface
Version: 5.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Jeff Fearn 🐞
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-03 05:06 UTC by Rony Gong 🔥
Modified: 2017-03-14 02:23 UTC (History)
6 users (show)

Fixed In Version: 5.0.3-rh24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1409559
Environment:
Last Closed: 2017-03-14 02:23:23 UTC


Attachments (Terms of Use)

Description Rony Gong 🔥 2017-02-03 05:06:26 UTC
+++ This bug was initially created as a clone of Bug #1409559 +++

Description of problem:
There's quite a few External trackers available. It's convenient to select corretn one by starting typing its name. This doesn't work in beta of B5.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. visit a bug details page (show_bug.cgi)
2. try to add external tracker: open "Add External Bug: Tracker" list by clicking it
3. start typing "TCMS"

Actual results:
Nothing, typing a tracker name has no effect

Expected results:
"TCMS test case" external tracker gets selected

--- Additional comment from Jeff Fearn on 2017-01-09 07:42:16 CST ---

This is because of the stupid "-- Do Not Change --" entry which is a default selected option, it should not exist and there should be no default selected option.

Work around: If you backspace away the default option, search works as expected.

--- Additional comment from Rony Gong on 2017-02-03 11:42:05 CST ---

Seems you only do this change on bug detail page, how about also do this change on the bug entry page?

--- Additional comment from Jeff Fearn on 2017-02-03 11:50:04 CST ---

(In reply to Rony Gong from comment #2)
> Seems you only do this change on bug detail page, how about also do this
> change on the bug entry page?

Clone the bug plz

Comment 1 Rony Gong 🔥 2017-03-13 01:34:23 UTC
Tested on QA environment(5.0.3-rh24)
Result: Pass


Note You need to log in before you can comment on or make changes to this bug.