Bug 140994 - Can not log out from GNOME
Can not log out from GNOME
Status: CLOSED DUPLICATE of bug 139138
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-27 11:04 EST by Juraj Bednar
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Juraj Bednar 2004-11-27 11:04:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I try to log out from GNOME desktop. I do logout, from the dialog,
where I can do either logout, reboot or shutdown, I choose logout
without or with saving status (does not matter). Then I click OK, the
dialog box disappears and from now on, it keeps hanging, without the
ability to click on anything (I still see the menu though).

When I go to text console and kill nautilus, I get logged out, so it
seems there is a problem with nautilus itself.

Gdb stack trace:

#0  0x004a47a2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x007e7ac6 in pthread_cond_wait@@GLIBC_2.3.2 ()
   from /lib/tls/libpthread.so.0
#2  0x0036a404 in link_wait () from /usr/lib/libORBit-2.so.0
#3  0x0036ba8b in link_connection_try_reconnect ()
   from /usr/lib/libORBit-2.so.0
#4  0x0034ae74 in giop_connection_try_reconnect ()
   from /usr/lib/libORBit-2.so.0
#5  0x00353e4e in ORBit_objref_get_proxy () from /usr/lib/libORBit-2.so.0
#6  0x003540a5 in ORBit_object_get_connection () from
/usr/lib/libORBit-2.so.0
#7  0x00351b88 in ORBit_small_invoke_stub () from /usr/lib/libORBit-2.so.0
#8  0x00351da9 in ORBit_small_invoke_stub_n () from
/usr/lib/libORBit-2.so.0
#9  0x003643a7 in ORBit_c_stub_invoke () from /usr/lib/libORBit-2.so.0
#10 0x024a1131 in GNOME_VFS_Daemon_getDrives ()
   from /usr/lib/libgnomevfs-2.so.0
#11 0x024cff7c in gnome_vfs_volume_monitor_client_get_type ()
   from /usr/lib/libgnomevfs-2.so.0
#12 0x024d0164 in gnome_vfs_volume_monitor_client_get_type ()
   from /usr/lib/libgnomevfs-2.so.0
#13 0x0079f2cc in g_type_create_instance () from
/usr/lib/libgobject-2.0.so.0
#14 0x007865a1 in g_object_new () from /usr/lib/libgobject-2.0.so.0
#15 0x0078583f in g_object_newv () from /usr/lib/libgobject-2.0.so.0
#16 0x00786459 in g_object_new_valist () from /usr/lib/libgobject-2.0.so.0
#17 0x00786578 in g_object_new () from /usr/lib/libgobject-2.0.so.0
#18 0x024d0949 in _gnome_vfs_get_volume_monitor_internal ()
   from /usr/lib/libgnomevfs-2.so.0
#19 0x024d09a0 in gnome_vfs_get_volume_monitor ()
   from /usr/lib/libgnomevfs-2.so.0
#20 0x08069440 in nautilus_application_get_spatial_window_list ()
#21 0x09d57578 in ?? ()
#22 0x047c47dc in bonobo_object_get_type () from /usr/lib/libbonobo-2.so.0



this is actually the same all the time I try to do this logout, so I
believe it clearly describes the problem. 

This is fairly basic fedora core 3 install, with only one specific,
that it uses NIS for authentication. It has all the updates until
today, including the kernel.

Version-Release number of selected component (if applicable):
nautilus-2.8.1-4

How reproducible:
Always

Steps to Reproduce:
See description

Additional info:
Comment 1 Juraj Bednar 2004-11-27 11:35:12 EST

*** This bug has been marked as a duplicate of 139138 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:07:17 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.