Bug 1410012 - Chargeback for Container Images - Default Container Image Rate is editable
Summary: Chargeback for Container Images - Default Container Image Rate is editable
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: GA
: 5.8.0
Assignee: Ari Zellner
QA Contact: Gilad Shefer
URL:
Whiteboard: container
Depends On: 1429189
Blocks: 1425492
TreeView+ depends on / blocked
 
Reported: 2017-01-04 08:31 UTC by Einat Pacifici
Modified: 2017-08-29 04:47 UTC (History)
8 users (show)

Fixed In Version: 5.8.0.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1425492 (view as bug list)
Environment:
Last Closed: 2017-06-12 16:45:49 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
Showing Enabled Menu item (204.81 KB, image/jpeg)
2017-01-04 08:31 UTC, Einat Pacifici
no flags Details

Description Einat Pacifici 2017-01-04 08:31:40 UTC
Created attachment 1237077 [details]
Showing Enabled Menu item

Description of problem:
When defining a new rate for chargeback of container Images, the predefined "Default Container Image Rate" can be edited. 
This causes CFME to be unable to produce any chargeback for images reports. 

Version-Release number of selected component (if applicable):
5.7.0.17

How reproducible:
Always

Steps to Reproduce:
1.Navigate to Cloud Intel --> Chargeback --> Rates
2.Select Default Container Image Rate
3.Click on Configuration button
4. View drop-down 

Actual results:
The menu item: Configuration --> Edit this Chargeback rate is enabled


Expected results:
The menu item: Configuration --> Edit this Chargeback rate should be disabled. 

Additional info:
The implication of being able to edit this specific rate is that once edited (e.g. change the rate's name) CFME is unable to generate any chargeback for images reports.

Comment 2 Šimon Lukašík 2017-01-05 13:49:35 UTC
https://github.com/ManageIQ/manageiq/pull/13359

Comment 3 Šimon Lukašík 2017-01-18 12:16:54 UTC
Ari, would you be willing to take a look into this one?

See discussion in https://github.com/ManageIQ/manageiq/pull/13359

Thanks a lot. I'll use the extra time for cleaning this up for the longterm.

Comment 4 Ari Zellner 2017-01-19 14:11:15 UTC
Simon, I think that if I make the name uneditable we should be done.
What do you think?

Comment 5 Šimon Lukašík 2017-01-19 14:33:25 UTC
What is the user story behind this container rate?

Based on the user-story for this default container compute rate, we could tell:
 - if it be true 'default' rate? What is meaning of default, really?
 - or Should we create new 'Compute for Containers'?

I don't know all this so I don't have a strong opinion. That being said, Ari, I will trust your judgment on what needs to be done here. :)

Comment 8 Gilad Shefer 2017-03-06 09:54:15 UTC
I tested under 5.8.03, the 'Default Container Image Rate' is editable.

Comment 9 Federico Simoncelli 2017-03-06 11:24:46 UTC
Ari how come this failed QE? Can you check with Gilad?
IIUC https://github.com/ManageIQ/manageiq-ui-classic/pull/269 was merged on the 21st of Feb and should have been in 5.8.0.3 (1st of Mar).

Comment 10 Ari Zellner 2017-03-12 13:07:16 UTC
Gilad, you should be able to edit the rates but NOT the description (which is the scenario that causes the problem)
Can you check again?

Comment 11 Einat Pacifici 2017-03-26 12:03:01 UTC
Ari, 

the UI behaviour for the "default rate" is different to the behaviour for the "default container image rate" 
In the default rate, the dropdown "Edit" button is not available to the user. 
In the default container image rate, the dropdown "Edit" is available, the user is able to edit the name of the rate, but, when pressing the "Add" button, the user is presented with an error: 
"Can not change description of 'Default Container Image Rate'"

Obviously this is very confusing to the user. 
So, indeed, the report will not be generated, but,the UI-UX is inconsistent. 
I am returning this BZ back to dev, to resolve the issue and disable the "edit" option for this rate, as is the behaviour of the "default" rate.

Comment 12 Barak 2017-03-30 11:54:46 UTC
Here is the status:

- From functionality point of view this is fully functional as defined by PMs:
  * "Default Container Image Rate" - is editabe (only rates not the name or description)
  * "Default Container Image Rate" - can not be deleted through the UI

The above is exactly the functionality defined by PM for this rate.
If one can not add/edit the amounts in this rate, there will be no default rates for containers. 


- This bug was reopened due to a UI inconsistent behaviour:
  * the fact the one can edit a default rate (the other default rate can not be edited)
  * when editing the "Default Container Image Rate" you can not edit the description (as the charge back engine looks for this defaule rate by name)


So Moving this bug to ON_QA and please verify the above functionality.

Please open a different bu on the UI inconsistencies.


Note You need to log in before you can comment on or make changes to this bug.