Bug 1410071 - [Geo-rep] Geo replication status detail without master and slave volume args
Summary: [Geo-rep] Geo replication status detail without master and slave volume args
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: x86_64
OS: Linux
medium
unspecified
Target Milestone: ---
Assignee: Sonal
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1089628
TreeView+ depends on / blocked
 
Reported: 2017-01-04 11:54 UTC by Kotresh HR
Modified: 2017-03-06 17:41 UTC (History)
13 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: Enhancement
Doc Text:
Clone Of: 843838
Environment:
Last Closed: 2017-03-06 17:41:22 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kotresh HR 2017-01-04 11:54:37 UTC
+++ This bug was initially created as a clone of Bug #843838 +++

Description of problem:
'gluster vol geo-rep status detail' doesn't work. It only works when master and slave volume args are given.

Version-Release number of selected component (if applicable):
mainline

How reproducible:
Always 


Steps to Reproduce:
1.Create a glustervolume and a Geo replication session
2.Run 'gluster vol geo-rep status detail'
  
Actual results:
The command fails with incorrect usage

Expected results:

It should not fail.

Additional info:

Comment 1 Worker Ant 2017-01-06 11:36:36 UTC
REVIEW: http://review.gluster.org/16347 (cli/src/cli-cmd-parser.c: Updated 'gluster vol geo-rep status detail') posted (#1) for review on master by Sonal Arora (sarora@redhat.com)

Comment 2 Worker Ant 2017-01-11 12:48:18 UTC
REVIEW: http://review.gluster.org/16347 (cli/geo-rep: Fix geo-rep status detail) posted (#2) for review on master by Sonal Arora (sarora@redhat.com)

Comment 3 Worker Ant 2017-01-11 17:07:12 UTC
REVIEW: http://review.gluster.org/16347 (cli/geo-rep: Fix geo-rep status detail) posted (#3) for review on master by Sonal Arora (sarora@redhat.com)

Comment 4 Worker Ant 2017-01-13 02:55:02 UTC
COMMIT: http://review.gluster.org/16347 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 27c85d014bb7d03c323e08038d9c6db538d632fb
Author: SonaArora <sarora@redhat.com>
Date:   Fri Jan 6 14:21:56 2017 +0530

    cli/geo-rep: Fix geo-rep status detail
    
    Earlier this command works when master and slave volume args are
    given. Now it works even when no volume args are given (i.e. 'gluster
    volume geo-replication status detail) and also when master volume is given
    (i.e.'gluster volume geo-replication <master-vol> status detail').
    
    BUG: 1410071
    Signed-off-by: SonaArora <sarora@redhat.com>
    Change-Id: I1a39241a4a5d70c20b2326599b3cccd8f1f6dc78
    Reviewed-on: http://review.gluster.org/16347
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Tested-by: Kotresh HR <khiremat@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Kotresh HR <khiremat@redhat.com>

Comment 5 Shyamsundar 2017-03-06 17:41:22 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.