Bug 843838 - [RFE] Enhancing geo-replication status to show details without inclusion of master/slave volume in the input cli
[RFE] Enhancing geo-replication status to show details without inclusion of ...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.0
x86_64 Linux
medium Severity unspecified
: ---
: RHGS 3.3.0
Assigned To: Kotresh HR
Rahul Hinduja
: EasyFix, FutureFeature
: 1286802 (view as bug list)
Depends On:
Blocks: 1443923 1417138 1436653
  Show dependency treegraph
 
Reported: 2012-07-27 10:13 EDT by Marcel Hergaarden
Modified: 2017-09-21 00:53 EDT (History)
13 users (show)

See Also:
Fixed In Version: glusterfs-3.8.4-19
Doc Type: Enhancement
Doc Text:
The detailed geo-replication status command no longer requires master volume, slave host, and slave volume, and can be run with or without these additional details, like so: gluster volume geo-replication status detail
Story Points: ---
Clone Of:
: 1410071 1436653 1443923 (view as bug list)
Environment:
Last Closed: 2017-09-21 00:25:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Aravinda VK 2014-12-24 00:43:44 EST
Seems related to bz 842315
Comment 3 Aravinda VK 2015-12-02 05:00:53 EST
*** Bug 1286802 has been marked as a duplicate of this bug. ***
Comment 4 Aravinda VK 2015-12-28 01:17:42 EST
Fix to done in $SRC/xlators/mgmt/glusterd/src/glusterd-geo-rep.c

Use slave* info from Volume dict
Comment 6 Jayaraj 2016-01-14 03:07:00 EST
Can we have this BZ implemented in rhgs-3.2.0? Please let us know to update the customer accordingly. 

Thanks,
Jay
Comment 8 Jayaraj 2016-04-18 05:09:13 EDT
Hi, May I have some update on this RFE?
Comment 9 Alok 2016-04-18 06:11:04 EDT
Is "Geo-replication status" not helping here? You can get the details from the below link:
https://access.redhat.com/documentation/en-US/Red_Hat_Storage/3.1/html/Administration_Guide/sect-Starting_Geo-replication.html#Displaying_Geo-replication_Status_Information
Comment 13 Kotresh HR 2017-02-22 02:10:08 EST
Upstream Patch:

https://review.gluster.org/#/c/16347/ (master)
It's in upstream 3.10 as part of branch out from master
Comment 15 Atin Mukherjee 2017-03-24 04:54:33 EDT
downstream patch : https://code.engineering.redhat.com/gerrit/#/c/101290/
Comment 18 Rahul Hinduja 2017-04-20 05:15:58 EDT
The expectation and the fix for this bug differs from the original description and comment 10:

Original requirement: 

* gluster volume info or gluster volume status should have information about geo-replication slave volume.

Changed requirement:

* Customer was ok to have it addressed via "geo-replication status detail" without using master/slave volume name as per comment 10:

Patch at comment 15 fixes the modified requirement to address this via status detail:

Comment 17: Confirms the verification

Changing the title to reflect what is required and fixed. Also, creating new rfe to track the original requirement(volume info) for future assessment.
Comment 19 Rahul Hinduja 2017-04-20 05:47:44 EDT
Moving this bug to verified state based on comment 18. Also, any future bugs in this area will be tracked by different bug id's.
Comment 21 Kotresh HR 2017-08-15 23:54:08 EDT
Could it be modified to indicate that the geo-rep status command now works with and with out master volume, slave host and slave volume ?
Comment 23 errata-xmlrpc 2017-09-21 00:25:52 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2774
Comment 24 errata-xmlrpc 2017-09-21 00:53:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2774

Note You need to log in before you can comment on or make changes to this bug.