Bug 1410159 - Missing panda and /usr/share/perl6/lib/* from recent builds
Summary: Missing panda and /usr/share/perl6/lib/* from recent builds
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: rakudo-star
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Gerd Pokorra
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1413184 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-04 15:52 UTC by Ian Morgan
Modified: 2017-05-21 14:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-21 14:14:37 UTC
Type: Bug


Attachments (Terms of Use)

Description Ian Morgan 2017-01-04 15:52:06 UTC
Description of problem:
The rakudo-star RPMs are missing panda and the entire contents of /usr/share/perl6/lib/ since the rakudo-star-0.0.2016.07-1 update.

Version-Release number of selected component (if applicable):
rakudo-star-0.0.2016.11-1.fc25.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Build the RPM from the SRPM
2.
3.

Actual results:
The elements that are supposed to make this rakudo-star, and not just rakudo, are not being packaged.

Expected results:
Package should include panda and the 'useful and usable' collection of modules.

Additional info:
If necessary, rename this package to rakudo, and make a separate perl6-panda package so we can at least easily install the missing modules.

Comment 1 Gerd Pokorra 2017-01-05 11:38:06 UTC
It is not possible to build the rakudo-star package with panda. I tried different
ways without success.

Since panda is the module manager for perl6 modules the rakudo-star package could include it.

$ rpm -qlp rakudo-star-0.0.2016.07-1.fc25.x86_64.rpm | grep /usr/share/perl6/lib 
/usr/share/perl6/lib
$

$ rpm -qlp rakudo-star-0.0.2016.07-1.fc25.x86_64.rpm | grep panda
$

I already considered to go back to the radudo package. This is not a simple rename. The package needed to be review again by somebody. See at:
https://bugzilla.redhat.com/show_bug.cgi?id=498390

perl6 from the package rakudo-star-0.0.2016.11-1.fc25.x86_64 works fine.

As workaround you need to build panda at your home directory by default the modules will be installed at ~/.perl6.

Comment 2 Gerd Pokorra 2017-01-05 11:43:54 UTC
Correction, I wanted to write in the prior comment:

Since panda is the module manager for perl6 modules the rakudo-star package could not be built to include the panda program.

Comment 3 Ian Morgan 2017-01-05 17:09:12 UTC
I would consider this to be a regression, since the earlier packages did indeed include panda and the bundle of modules. It was indeed what rakudo-star should be. The new packages continue to claim to be rakudo-star but have in fact removed that functionality and now only provide rakudo without the extras that really make up rakudo-star. This caused existing systems to break when the upgraded packages removed pre-exiting functionality. And the changelogs made no indication of this to warn the user that the new packages would no longer be compatible with the old ones.

I understand the complexity of getting panda and the additional modules to be built/installed within the buildroot environment. I tried myself before reporting this issue. I am no RPM packaging guru, but would be willing to give it a go again and provide a patch/updated SPEC file if you'll accept it.

Comment 4 Gerd Pokorra 2017-01-05 22:40:15 UTC
Getting a patch or complete SPEC file that fix the problem would be great. 

At

https://koji.fedoraproject.org/koji/packageinfo?packageID=10898

you can find the rakudo-star builds. I checked rakudo-star-0.0.2016.07-1.fc25 for panda but did not found the program included.

Comment 5 Gerd Pokorra 2017-01-13 23:22:09 UTC
*** Bug 1413184 has been marked as a duplicate of this bug. ***

Comment 6 Todd 2017-01-14 21:27:53 UTC
Perl 6 is pretty useless without the modules.  Any sign of them in our future?

Comment 7 Todd 2017-02-24 07:28:16 UTC
I am dying here without panda, especially since it won't build from github.  Any sign of a panda rpm in the immediate future?

Comment 8 Todd 2017-02-24 08:50:46 UTC
Idea: use "zef" instead.  It works a lot better than panda anyway:
https://github.com/ugexe/zef/

Install zef:
    $ git clone https://github.com/ugexe/zef.git
    $ cd zef
    $ perl6 -Ilib bin/zef install .


USAGE

Note: run as a user

    zef --help

    # install the CSV::Parser distribution   (it will also install dependancies)
    zef install CSV::Parser
    zef install Net::SMTP

Comment 9 Gerd Pokorra 2017-03-02 09:27:46 UTC
In the sources of the current rakudo-star release 2017.01 (http://rakudo.org/downloads/star/rakudo-star-2017.01.tar.gz) zef is the Perl6 module manager.

Installing zef require an installed rakudo (perl6). So zef can not be builded in one step together with rakudo and included in the radudo-star package. For this reason the plan is to invoke the rakudo package again and to retire the rakudo-star package.

I find someone who is doing the review of the rakudo package again. The URL of the rakudo review is:
https://bugzilla.redhat.com/show_bug.cgi?id=498390

I will leave this ticket open to report on the latest state.

Comment 10 Gerd Pokorra 2017-05-21 14:14:37 UTC
The rakudo-star package is replaced by rakudo.

Rakudo 2017.04.2 is in Fedora 25 and higher:
    $ rpm -q rakudo
    rakudo-0.2017.04.2-1.fc25.x86_64

A review request of zef is done at:

https://bugzilla.redhat.com/show_bug.cgi?id=1452985


Note You need to log in before you can comment on or make changes to this bug.